summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-08-20 08:08:18 +0200
committerMichał Górny <mgorny@gentoo.org>2020-08-20 10:34:36 +0200
commite6d77459521baf646ed59e9a40dc21d9474e9e4e (patch)
tree67413e4978332774c40bc473d670c6fe35d7c9ee
parentdev-python/botocore: Bump to 1.17.46 (diff)
downloadgentoo-e6d77459.tar.gz
gentoo-e6d77459.tar.bz2
gentoo-e6d77459.zip
dev-python/boto3: Bump to 1.14.46
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.14.46.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 5ed97ebcd526..d6d961abb532 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -6,3 +6,4 @@ DIST boto3-1.14.28.tar.gz 299959 BLAKE2B 7318fd60ccd46e12f38eb14aeecfb59fd951ed9
DIST boto3-1.14.31.tar.gz 300720 BLAKE2B 9dbd002e299c629f28037572c615a00612c80773006c344797d0ad56c81c240b56bfc56e8ffe52e3b404c77a56318532aadfa2d008c254e70f7bfa91e40b7e1a SHA512 e3fe0041bbdc67affcf5d5272c26aa14ef0fa546af2efb99187311bee23531181ab1f1ebc69f2c3ed8250140642f4402334ebbc9acbf422641fa6abed5d5815f
DIST boto3-1.14.34.tar.gz 300890 BLAKE2B 0f8883ee4edc100207be68b93a5510fcb807adb860c0292cab9a6c2eaab238735f3ed01608ab7763f27d4eacb23e57beb289511ec83770ac91f33e044e5e9425 SHA512 cfe84bf5a1ea99905dbddcc63665bcd8e310cd0fdc37b1990c722ae6ca91e7c2adb17a8305eed19df0a6761f1c0c0c62cb935bd37d2360d84ea746753117a16b
DIST boto3-1.14.43.tar.gz 301496 BLAKE2B 0d2f33679c89f65e1866e7209c634da055666cd6d63a3c0b048a9855baaa16148c54aaf60b450abb9cc98fae1881269e6087c45a6fea5e00096f39c4c3649491 SHA512 35394136d89e9b9c6b1d8703c2023b07f8c0019561eec481391f932977cfd43e1b73d99531cef6fbf1f05d96f01b7cd015dd7b1f352c54053269f40c5074bea2
+DIST boto3-1.14.46.tar.gz 301815 BLAKE2B e389e7e0cd9ed0907fd13a948bf37e00040e32029d7720f5a720c8c9cb3cf1fb157bb665032b4ba594b3b5f50129088f26f004535fc4f8fe72f32ab0be6ce9b9 SHA512 aa1aa0155fcaaaddcfc24697211e8f5a69eab1282a185f0cb76b02d63d1426c02ca3be71be980214484a351159f6bcc34c3422cd11b9a556d67802c01a06aed0
diff --git a/dev-python/boto3/boto3-1.14.46.ebuild b/dev-python/boto3/boto3-1.14.46.ebuild
new file mode 100644
index 000000000000..ccc99e1c2415
--- /dev/null
+++ b/dev-python/boto3/boto3-1.14.46.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # prevent an infinite loop
+ rm tests/functional/docs/test_smoke.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests -v tests/unit/ tests/functional/ || die "test failed under ${EPYTHON}"
+}