summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorQuentin Retornaz <gentoo@retornaz.com>2021-03-06 21:04:19 +0100
committerJoonas Niilola <juippis@gentoo.org>2021-03-08 18:31:59 +0200
commite6df77f2c4bc938abbdeeffb341df9e997fc548e (patch)
tree1bdc7f1839db3fd2d2e478820491402e493fe60a
parentnet-wireless/unifi: bump to 6.1.67 (diff)
downloadgentoo-e6df77f2c4bc938abbdeeffb341df9e997fc548e.tar.gz
gentoo-e6df77f2c4bc938abbdeeffb341df9e997fc548e.tar.bz2
gentoo-e6df77f2c4bc938abbdeeffb341df9e997fc548e.zip
net-analyzer/nikto: version bump to 2.1.6_p20210304
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Quentin Retornaz <gentoo@retornaz.com> Closes: https://github.com/gentoo/gentoo/pull/19799 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--net-analyzer/nikto/Manifest1
-rw-r--r--net-analyzer/nikto/nikto-2.1.6_p20210304.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/net-analyzer/nikto/Manifest b/net-analyzer/nikto/Manifest
index be93f585da68..4f81fbf790d9 100644
--- a/net-analyzer/nikto/Manifest
+++ b/net-analyzer/nikto/Manifest
@@ -1 +1,2 @@
DIST nikto-2.1.6_p20200901.tar.gz 521285 BLAKE2B 243f0baf5835e5586b8270fc9dd1005c08e903f478666359c34bb0d30c0645f5ab9a19109718dbbd2f6015dcb64c3a98b832b5412c9151720dedd102fb1936d1 SHA512 88b9e681ce4588e3473f90c93ea41d46fc99a54b895185465cfe1a28152ad944edbadfcf5cee4540b4ec48eb78ca73a1952637c3da9038e52d837c0de5d0260c
+DIST nikto-2.1.6_p20210304.tar.gz 521719 BLAKE2B 66715e109dfb47bb5ed6b64cfff4dbdd0667883e5ce28c26a7325645fe42ccfdcb6f9bcf956adce6f626c51ff363122724955eda86c715d4f8ec4894ebf1ae4a SHA512 d78cedad0b2f96d02964097699d5765fdb895b7ec1a9e196cbf9181888dd19cfca7d912f172a870e4b8bd2b53e4fc41407a60ed129ef24592909ef6111d04a0e
diff --git a/net-analyzer/nikto/nikto-2.1.6_p20210304.ebuild b/net-analyzer/nikto/nikto-2.1.6_p20210304.ebuild
new file mode 100644
index 000000000000..4465e68730cd
--- /dev/null
+++ b/net-analyzer/nikto/nikto-2.1.6_p20210304.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Web server vulnerability scanner"
+HOMEPAGE="https://www.cirt.net/Nikto2"
+COMMIT="8a4b5fb86ae8a1b4f31c32da0bcedd3bcaf4deb8"
+MY_P="${PN}-${COMMIT}"
+SRC_URI="https://github.com/sullo/nikto/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+# nikto provides its own libwhisker, do no use net-libs/libwhisker[ssl]
+# https://bugs.gentoo.org/533900
+RDEPEND="
+ dev-lang/perl
+ dev-perl/Net-SSLeay
+ net-analyzer/nmap
+ virtual/perl-JSON-PP
+"
+
+S="${WORKDIR}/${MY_P}/program"
+
+src_prepare() {
+ sed -i -e 's:/etc/nikto.conf:/etc/nikto/nikto.conf:' nikto.pl || die
+ sed -i -e 's:# EXECDIR=/opt/nikto:EXECDIR=/usr/share/nikto:' nikto.conf.default || die
+
+ default
+}
+
+src_install() {
+ insinto /etc/nikto
+ newins nikto.conf.default nikto.conf
+
+ dobin nikto.pl replay.pl
+ dosym nikto.pl /usr/bin/nikto
+
+ insinto /usr/share/nikto
+ doins -r plugins templates databases
+
+ dodoc docs/*.txt
+ dodoc docs/nikto_manual.html
+}