summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2023-10-18 17:40:44 +0300
committerJoonas Niilola <juippis@gentoo.org>2024-01-10 11:06:07 +0200
commite6e1f421a276080114008991ded9b1a2a3772cc0 (patch)
tree22251e5bbb89ad5f3907a49d9d57b8186b722f3d
parentnet-analyzer/pontos: drop patch, use EPYTEST_DESELECT and pytest runner (diff)
downloadgentoo-e6e1f421a276080114008991ded9b1a2a3772cc0.tar.gz
gentoo-e6e1f421a276080114008991ded9b1a2a3772cc0.tar.bz2
gentoo-e6e1f421a276080114008991ded9b1a2a3772cc0.zip
www-servers/pound: add 4.10
Updated to new upstream, several fixes to ebuild and init-script. Closes: https://bugs.gentoo.org/829652 Closes: https://bugs.gentoo.org/807331 Closes: https://bugs.gentoo.org/804990 Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/33395 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--www-servers/pound/Manifest1
-rw-r--r--www-servers/pound/files/pound.init18
-rw-r--r--www-servers/pound/metadata.xml3
-rw-r--r--www-servers/pound/pound-4.10.ebuild47
4 files changed, 69 insertions, 0 deletions
diff --git a/www-servers/pound/Manifest b/www-servers/pound/Manifest
index 5dc91f413afe..751f3d7fe38f 100644
--- a/www-servers/pound/Manifest
+++ b/www-servers/pound/Manifest
@@ -1 +1,2 @@
DIST Pound-3.0.2.tgz 76000 BLAKE2B 0e3f2dc69771a1d1f3de00a721f02cdc4ff31f4d17ab81f64c368668f03c0c1f12484e2d40e7c1d2d203b033488f2bad57cafd8da5022dfe680a09cdc6b73bec SHA512 4c96a93df2b340049778ed7782377e521fbdd7b6ccaa157748b05941ac7a825b2688f37f3081a7e577b2fa1ec4f64d68a25d27af2210f59da5be0dc10d1391e9
+DIST pound-4.10.tar.gz 554678 BLAKE2B 895ee69bcbac680062af270655af3433daffd60ea7a90875dd1fb867447a9be6b28d18444db758fa9c034002ab256fc76d932b893a426d77b6069e03a63a7e74 SHA512 2e0fadbcdeb87fb8357c14467b7b31e598881e7db7bde725f81fb4668370cad993e00a9c7617ff4343a444393f05521cda6c8e1b3d663af6b5053b7c7fd7c874
diff --git a/www-servers/pound/files/pound.init b/www-servers/pound/files/pound.init
new file mode 100644
index 000000000000..ff2322ea2189
--- /dev/null
+++ b/www-servers/pound/files/pound.init
@@ -0,0 +1,18 @@
+#!/sbin/openrc-run
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+name="Pound daemon"
+description=""
+command="/usr/sbin/pound"
+pidfile="/var/run/pound.pid"
+command_args="-f /etc/pound.cfg -p ${pidfile}"
+
+depend() {
+ need net
+}
+
+start_pre() {
+ checkpath --file /etc/pound.cfg
+}
+
diff --git a/www-servers/pound/metadata.xml b/www-servers/pound/metadata.xml
index 0a0f6e053ff8..9635b947182e 100644
--- a/www-servers/pound/metadata.xml
+++ b/www-servers/pound/metadata.xml
@@ -9,6 +9,9 @@
<email>proxy-maint@gentoo.org</email>
<name>Proxy Maintainers</name>
</maintainer>
+ <upstream>
+ <remote-id type="github">graygnuorg/pound</remote-id>
+ </upstream>
<longdescription lang="en">
The Pound program is a reverse proxy, load balancer
and HTTPS front-end for Web server(s). Pound was developed to enable
diff --git a/www-servers/pound/pound-4.10.ebuild b/www-servers/pound/pound-4.10.ebuild
new file mode 100644
index 000000000000..d9159cddc0a4
--- /dev/null
+++ b/www-servers/pound/pound-4.10.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="A http/https reverse-proxy and load-balancer"
+HOMEPAGE="https://github.com/graygnuorg/pound"
+SRC_URI="https://github.com/graygnuorg/pound/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+
+DEPEND="
+ dev-libs/openssl:=
+ dev-libs/libpcre2:=
+"
+RDEPEND="
+ ${DEPEND}
+ virtual/libcrypt:=
+"
+
+QA_CONFIG_IMPL_DECL_SKIP=(
+ PCRE2regcomp # Detecting broken Debian patched PCRE2
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=(
+ --with-owner=root
+ --with-group=root
+ )
+ econf ${myconf[@]}
+}
+
+src_install() {
+ default
+ newinitd "${FILESDIR}/pound.init" pound
+ insinto /etc
+ newins "${FILESDIR}/pound-2.2.cfg" pound.cfg
+}