summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Barker <alex@1stleg.com>2020-03-30 09:12:11 -0700
committerJames Le Cuirot <chewi@gentoo.org>2020-04-28 23:54:53 +0100
commite6edf4db508c9d80eb285fcbff4be119ea96edfa (patch)
tree73cbde9e981a5dc129f66c9345e815dc9e1a933b
parentdev-python/libcloud-3.0.0: Version bump (diff)
downloadgentoo-e6edf4db.tar.gz
gentoo-e6edf4db.tar.bz2
gentoo-e6edf4db.zip
games-emulation/advancemame-3.9: Version Bump
Bug: https://bugs.gentoo.org/665770 Closes: https://bugs.gentoo.org/665770 Signed-off-by: Alex Barker <alex@1stleg.com> Closes: https://github.com/gentoo/gentoo/pull/15173 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
-rw-r--r--games-emulation/advancemame/Manifest3
-rw-r--r--games-emulation/advancemame/advancemame-3.9.ebuild (renamed from games-emulation/advancemame/advancemame-3.7.ebuild)40
-rw-r--r--games-emulation/advancemame/files/advancemame-3.7-move_aclocal_to_acinclude.patch78
-rw-r--r--games-emulation/advancemame/files/advancemame-3.7-remove_static_configure_option.patch41
-rw-r--r--games-emulation/advancemame/files/advancemame-3.9-pkgconfig_for_ncurses_and_slang.patch184
-rw-r--r--games-emulation/advancemame/files/advancemame-pic.patch (renamed from games-emulation/advancemame/files/advancemame-1.2-pic.patch)0
-rw-r--r--games-emulation/advancemame/files/advancemame-verboselog.patch (renamed from games-emulation/advancemame/files/advancemame-1.2-verboselog.patch)0
7 files changed, 207 insertions, 139 deletions
diff --git a/games-emulation/advancemame/Manifest b/games-emulation/advancemame/Manifest
index 43195af92964..828db8897595 100644
--- a/games-emulation/advancemame/Manifest
+++ b/games-emulation/advancemame/Manifest
@@ -1,2 +1 @@
-DIST advancemame-3.7-use_pkgconfig_for_freetype_and_sdl.patch 21144 BLAKE2B ba374d664db45f938d3b054820868b5aaa63a7461938f5e8a320dc607ef3444c8fc5f87cdd3ef9db130c1048ef9e75afed4f856997f048bcb44eb99d3bcbaefc SHA512 80136d71117329997846fe0f03a3cf3439ee8ff3db649f50a3008595ed2d82cd0e3dcd9c6908edf30e19d516943eeed129eb994a6326effaf94a7eaa5d1b8fa2
-DIST advancemame-3.7.tar.gz 25616260 BLAKE2B 455004ff7ce3f7517c6b06767e9d1656bff6b93f822d363cbd42738e0f9ba988c243f600db5f20e24897c27faaf5c458072e2bc9c97cf92803f76299cf3010b8 SHA512 b5af59cdd3cf70dfae0769ed35eb6ce00a6f01d05eefcb687f322420faa2ee5aabf83394249c2ab7f7f1241d3fd09c2f0412666b2dbd27b91e7bc3622f925f74
+DIST advancemame-3.9.tar.gz 27287755 BLAKE2B 020a10a9b9fa207a733747273e749b4d9adabbd50104ae10b1568144bcdcb3694fe19e4ca5fd31119a02c64bca9872b1b3d1eb3ce305a611f006a8168f5bcb89 SHA512 43f9ba746f222b17ade2d213d6af7cc8fe6b3ee6008633f02b8877f4c7f75628bdf1cc9718db09f5f9a482d194c8ba94f9047334e8012d23c598454e5dab2eb3
diff --git a/games-emulation/advancemame/advancemame-3.7.ebuild b/games-emulation/advancemame/advancemame-3.9.ebuild
index c371c14107c3..08968fbd325d 100644
--- a/games-emulation/advancemame/advancemame-3.7.ebuild
+++ b/games-emulation/advancemame/advancemame-3.9.ebuild
@@ -1,51 +1,53 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit autotools flag-o-matic
DESCRIPTION="GNU/Linux port of the MAME emulator with GUI menu"
HOMEPAGE="http://www.advancemame.it/"
SRC_URI="https://github.com/amadvance/advancemame/releases/download/v${PV}/${P}.tar.gz"
-# Fetch too big upstream patch
-SRC_URI+=" https://github.com/amadvance/advancemame/commit/70f099ac49786a287ebd3949ce8f8670a5731abd.patch -> ${PN}-3.7-use_pkgconfig_for_freetype_and_sdl.patch"
-
LICENSE="GPL-2 XMAME"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="alsa fbcon oss truetype"
+IUSE="alsa fbcon ncurses oss slang truetype"
# sdl is required (bug #158417)
-RDEPEND="
- app-arch/unzip
- app-arch/zip
+DEPEND="
dev-libs/expat
- media-libs/libsdl2
+ media-libs/libsdl2[video]
sys-libs/zlib
alsa? ( media-libs/alsa-lib )
+ ncurses? ( sys-libs/ncurses )
+ slang? ( sys-libs/slang )
truetype? ( media-libs/freetype:2 )
"
-DEPEND="${RDEPEND}
- virtual/os-headers
+RDEPEND="
+ ${DEPEND}
+ app-arch/unzip
+ app-arch/zip
+"
+BDEPEND="
virtual/pkgconfig
x86? ( >=dev-lang/nasm-0.98 )
"
PATCHES=(
- "${FILESDIR}/${PN}-1.2-pic.patch"
- "${FILESDIR}"/${PN}-1.2-verboselog.patch
+ "${FILESDIR}"/${PN}-pic.patch
+ "${FILESDIR}"/${PN}-verboselog.patch
# Patches from upstream
- "${FILESDIR}/${P}-move_aclocal_to_acinclude.patch"
- "${DISTDIR}/${P}-use_pkgconfig_for_freetype_and_sdl.patch"
- "${FILESDIR}/${P}-remove_static_configure_option.patch"
+ "${FILESDIR}"/${P}-pkgconfig_for_ncurses_and_slang.patch
)
src_prepare() {
default
- eautoreconf
+ # AC_CHECK_CC_OPT is obsolete, superseded by AX_CHECK_COMPILE_FLAG
+ sed -i -e 's/AC_CHECK_CC_OPT/AX_CHECK_COMPILE_FLAG/' configure.ac || die
+
+ eautoreconf
sed -i -e 's/"-s"//' configure || die
use x86 && ln -s $(type -P nasm) "${T}/${CHOST}-nasm"
@@ -68,7 +70,9 @@ src_configure() {
--disable-svgalib \
$(use_enable alsa) \
$(use_enable fbcon fb) \
+ $(use_enable ncurses) \
$(use_enable oss) \
+ $(use_enable slang) \
$(use_enable truetype freetype) \
$(use_enable x86 asm)
}
diff --git a/games-emulation/advancemame/files/advancemame-3.7-move_aclocal_to_acinclude.patch b/games-emulation/advancemame/files/advancemame-3.7-move_aclocal_to_acinclude.patch
deleted file mode 100644
index 4a30e179ae27..000000000000
--- a/games-emulation/advancemame/files/advancemame-3.7-move_aclocal_to_acinclude.patch
+++ /dev/null
@@ -1,78 +0,0 @@
-From b0edfe1e5bb1a705fad539e5ab1c299d38dcf9d4 Mon Sep 17 00:00:00 2001
-From: Andrea Mazzoleni <amadvance@gmail.com>
-Date: Tue, 8 May 2018 18:55:39 +0200
-Subject: [PATCH 1/3] Use acinclude instead of aclocal
-
-aclocal.m4 is generated automatically, and we don't have to lose the content.
----
- acinclude.m4 | 20 ++++++++++++++++++++
- aclocal.m4 | 29 ++++++++++++-----------------
- 2 files changed, 32 insertions(+), 17 deletions(-)
- create mode 100644 acinclude.m4
-
-diff --git a/acinclude.m4 b/acinclude.m4
-new file mode 100644
-index 00000000..ceed823a
---- /dev/null
-+++ b/acinclude.m4
-@@ -0,0 +1,20 @@
-+dnl @synopsis AC_CHECK_CC_OPT(flag, ifyes, ifno)
-+dnl
-+dnl Shows a message as like "checking wether gcc accepts flag ... no"
-+dnl and executess ifyes or ifno.
-+
-+AC_DEFUN([AC_CHECK_CC_OPT],
-+[
-+AC_MSG_CHECKING([whether ${CC-cc} accepts $1])
-+echo 'void f(){}' > conftest.c
-+if test -z "`${CC-cc} -c $1 conftest.c 2>&1`"; then
-+ AC_MSG_RESULT([yes])
-+ $2
-+else
-+ AC_MSG_RESULT([no])
-+ $3
-+fi
-+rm -f conftest*
-+])
-+
-+
-diff --git a/aclocal.m4 b/aclocal.m4
-index d6e7b527..56e944be 100644
---- a/aclocal.m4
-+++ b/aclocal.m4
-@@ -1,20 +1,15 @@
--dnl @synopsis AC_CHECK_CC_OPT(flag, ifyes, ifno)
--dnl
--dnl Shows a message as like "checking wether gcc accepts flag ... no"
--dnl and executess ifyes or ifno.
-+# generated automatically by aclocal 1.15 -*- Autoconf -*-
-
--AC_DEFUN(AC_CHECK_CC_OPT,
--[
--AC_MSG_CHECKING([whether ${CC-cc} accepts $1])
--echo 'void f(){}' > conftest.c
--if test -z "`${CC-cc} -c $1 conftest.c 2>&1`"; then
-- AC_MSG_RESULT([yes])
-- $2
--else
-- AC_MSG_RESULT([no])
-- $3
--fi
--rm -f conftest*
--])
-+# Copyright (C) 1996-2014 Free Software Foundation, Inc.
-
-+# This file is free software; the Free Software Foundation
-+# gives unlimited permission to copy and/or distribute it,
-+# with or without modifications, as long as this notice is preserved.
-
-+# This program is distributed in the hope that it will be useful,
-+# but WITHOUT ANY WARRANTY, to the extent permitted by law; without
-+# even the implied warranty of MERCHANTABILITY or FITNESS FOR A
-+# PARTICULAR PURPOSE.
-+
-+m4_ifndef([AC_CONFIG_MACRO_DIRS], [m4_defun([_AM_CONFIG_MACRO_DIRS], [])m4_defun([AC_CONFIG_MACRO_DIRS], [_AM_CONFIG_MACRO_DIRS($@)])])
-+m4_include([acinclude.m4])
---
-2.17.0
-
diff --git a/games-emulation/advancemame/files/advancemame-3.7-remove_static_configure_option.patch b/games-emulation/advancemame/files/advancemame-3.7-remove_static_configure_option.patch
deleted file mode 100644
index 342ba1c5c07a..000000000000
--- a/games-emulation/advancemame/files/advancemame-3.7-remove_static_configure_option.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-From 890af36a3939f0978af779caa878ddeb44183d8d Mon Sep 17 00:00:00 2001
-From: Andrea Mazzoleni <amadvance@gmail.com>
-Date: Tue, 8 May 2018 19:32:44 +0200
-Subject: [PATCH 3/3] Remove the --enable-static configure option
-
-I doubt it still work and it doesn't make sense anymore.
----
- configure.ac | 10 ----------
- 1 file changed, 10 deletions(-)
-
-diff --git a/configure.ac b/configure.ac
-index 4e609993..1c94e037 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -139,13 +139,6 @@ AC_ARG_ENABLE(
- )
- AC_SUBST([CONF_DEBUG],[$ac_enable_debug])
-
--AC_ARG_ENABLE(
-- [static],
-- AC_HELP_STRING([--enable-static],[enable static compilation. (default no)]),
-- [ac_enable_static=$enableval],
-- [ac_enable_static=no]
--)
--
- AC_ARG_ENABLE(
- [bare],
- AC_HELP_STRING([--enable-bare],[enable compilation without drivers. (default no)]),
-@@ -232,9 +225,6 @@ if test $ac_auto_ldflags = yes ; then
- else
- LDFLAGS="-s"
- fi
-- if test $ac_enable_static = yes ; then
-- LDFLAGS="-static $LDFLAGS"
-- fi
- if test ! -z $ac_host_ldflags; then
- LDFLAGS="$ac_host_ldflags $LDFLAGS"
- fi
---
-2.17.0
-
diff --git a/games-emulation/advancemame/files/advancemame-3.9-pkgconfig_for_ncurses_and_slang.patch b/games-emulation/advancemame/files/advancemame-3.9-pkgconfig_for_ncurses_and_slang.patch
new file mode 100644
index 000000000000..b91c887e030f
--- /dev/null
+++ b/games-emulation/advancemame/files/advancemame-3.9-pkgconfig_for_ncurses_and_slang.patch
@@ -0,0 +1,184 @@
+diff --git a/Makefile.in b/Makefile.in
+index 4e30ada3..e92a1072 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -27,6 +27,8 @@ CONF_LIB_ALSA=@CONF_LIB_ALSA@
+ CONF_LIB_OSS=@CONF_LIB_OSS@
+ CONF_LIB_SDL=@CONF_LIB_SDL@
+ CONF_LIB_FREETYPE=@CONF_LIB_FREETYPE@
++CONF_LIB_SLANG=@CONF_LIB_SLANG@
++CONF_LIB_NCURSES=@CONF_LIB_NCURSES@
+ CONF_LIB_SVGAWIN=@CONF_LIB_SVGAWIN@
+ CONF_LIB_PTHREAD=@CONF_LIB_PTHREAD@
+ CONF_LIB_SLANG=@CONF_LIB_SLANG@
+@@ -97,6 +99,10 @@ SDLCFLAGS=@SDLCFLAGS@
+ SDLLIBS=@SDLLIBS@
+ FREETYPECFLAGS=@FREETYPECFLAGS@
+ FREETYPELIBS=@FREETYPELIBS@
++SLANGCFLAGS=@SLANGCFLAGS@
++SLANGLIBS=@SLANGLIBS@
++NCURSESCFLAGS=@NCURSESCFLAGS@
++NCURSESLIBS=@NCURSESLIBS@
+ VCCFLAGS=@VCCFLAGS@
+ VCLIBS=@VCLIBS@
+ ASMFLAGS=@ASMFLAGS@
+diff --git a/advance/cfg.mak b/advance/cfg.mak
+index 222533ff..d2f83233 100644
+--- a/advance/cfg.mak
++++ b/advance/cfg.mak
+@@ -57,15 +57,17 @@ CFGOBJS += \
+ $(CFGOBJ)/linux/os.o
+ ifeq ($(CONF_LIB_SLANG),yes)
+ CFGCFLAGS += \
++ $(SLANGCFLAGS) \
+ -DUSE_VIDEO_SLANG
+-CFGLIBS += -lslang
++CFGLIBS += $(SLANGLIBS)
+ CFGOBJS += \
+ $(CFGOBJ)/linux/vslang.o
+ endif
+ ifeq ($(CONF_LIB_NCURSES),yes)
+ CFGCFLAGS += \
++ $(NCURSESCFLAGS) \
+ -DUSE_VIDEO_CURSES
+-CFGLIBS += -lncurses
++CFGLIBS += $(NCURSESLIBS)
+ CFGOBJS += \
+ $(CFGOBJ)/linux/vcurses.o
+ endif
+diff --git a/advance/v.mak b/advance/v.mak
+index 4ffe708f..451f0d55 100644
+--- a/advance/v.mak
++++ b/advance/v.mak
+@@ -53,15 +53,17 @@ VOBJS += \
+ $(VOBJ)/linux/os.o
+ ifeq ($(CONF_LIB_SLANG),yes)
+ VCFLAGS += \
++ $(SLANGCFLAGS) \
+ -DUSE_VIDEO_SLANG
+-VLIBS += -lslang
++VLIBS += $(SLANGLIBS)
+ VOBJS += \
+ $(VOBJ)/linux/vslang.o
+ endif
+ ifeq ($(CONF_LIB_NCURSES),yes)
+ VCFLAGS += \
++ $(NCURSESCFLAGS) \
+ -DUSE_VIDEO_CURSES
+-VLIBS += -lncurses
++VLIBS += $(NCURSESLIBS)
+ VOBJS += \
+ $(VOBJ)/linux/vcurses.o
+ endif
+diff --git a/configure.ac b/configure.ac
+index 063c407a..f8ba989a 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -717,29 +717,41 @@ AC_ARG_ENABLE(
+ [ac_lib_slang=auto]
+ )
+ if test $ac_lib_slang = auto; then
+- AC_CHECK_LIB(
+- [slang],
+- [SLang_init_tty],
+- [ac_lib_slang=yes],
+- [ac_lib_slang=no],
+- []
+- )
++ PKG_CHECK_MODULES([SLANG], [slang], [ac_lib_slang=yes], [ac_lib_slang=no])
++ if test $ac_lib_slang = yes; then
++ ac_save_CFLAGS="$CFLAGS"
++ ac_save_LIBS="$LIBS"
++ CFLAGS="SLANG_CFLAGS $CFLAGS"
++ LIBS="$SLANG_LIBS $LIBS"
++ AC_MSG_CHECKING([for linking slang])
++ AC_TRY_LINK([
++ #include <slang.h>
++ ], [
++ if (SLang_init_tty(-1, 0, 0) < 0) {
++ perror("SLang_init_tty");
++ return 1;
++ }
++
++ SLang_reset_tty();
++ return 0;
++ ],[ac_lib_slang=yes],[ac_lib_slang=no])
++ AC_MSG_RESULT([$ac_lib_slang])
++ CFLAGS="$ac_save_CFLAGS"
++ LIBS="$ac_save_LIBS"
++ fi
+ elif test $ac_lib_slang = yes; then
+- AC_CHECK_LIB(
+- [slang],
+- [SLang_init_tty],
+- [],
+- [AC_MSG_ERROR([the sLang library is missing])],
+- []
+- )
++ PKG_CHECK_MODULES([SLANG], [slang], [], AC_MSG_ERROR([the slang library is missing]))
+ fi
+ if test $ac_lib_slang = yes; then
+ AC_CHECK_HEADERS([slang.h slang/slang.h], [break])
+ ac_lib_video="$ac_lib_video slang"
+ ac_lib_text_flag=yes
+ fi
++AC_SUBST([SLANGCFLAGS],[$SLANG_CFLAGS])
++AC_SUBST([SLANGLIBS],[$SLANG_LIBS])
+ AC_SUBST([CONF_LIB_SLANG],[$ac_lib_slang])
+
++
+ dnl Checks for ncurses
+ AC_ARG_ENABLE(
+ [ncurses],
+@@ -748,28 +760,37 @@ AC_ARG_ENABLE(
+ [ac_lib_ncurses=auto]
+ )
+ if test $ac_lib_ncurses = auto; then
+- AC_CHECK_LIB(
+- [ncurses],
+- [endwin],
+- [ac_lib_ncurses=yes],
+- [ac_lib_ncurses=no],
+- []
+- )
++ PKG_CHECK_MODULES([NCURSES], [ncurses], [ac_lib_ncurses=yes], [ac_lib_ncurses=no])
++ if test $ac_lib_ncurses = yes; then
++ ac_save_CFLAGS="$CFLAGS"
++ ac_save_LIBS="$LIBS"
++ CFLAGS="$NCURSES_CFLAGS $CFLAGS"
++ LIBS="$NCURSES_LIBS $LIBS"
++ AC_MSG_CHECKING([for linking ncurses])
++ AC_TRY_LINK([
++ #include <ncurses.h>
++ ], [
++ initscr();
++ noecho();
++ curs_set(FALSE);
++ endwin();
++ ],[ac_lib_ncurses=yes],[ac_lib_ncurses=no])
++ AC_MSG_RESULT([$ac_lib_ncurses])
++ CFLAGS="$ac_save_CFLAGS"
++ LIBS="$ac_save_LIBS"
++ fi
+ elif test $ac_lib_ncurses = yes; then
+- AC_CHECK_LIB(
+- [ncurses],
+- [endwin],
+- [],
+- [AC_MSG_ERROR([the sLang library is missing])],
+- []
+- )
++ PKG_CHECK_MODULES([NCURSES], [ncurses], [], AC_MSG_ERROR([the ncurses library is missing]))
+ fi
+ if test $ac_lib_ncurses = yes; then
+ ac_lib_video="$ac_lib_video ncurses"
+ ac_lib_text_flag=yes
+ fi
++AC_SUBST([NCURSESCFLAGS],[$NCURSES_CFLAGS])
++AC_SUBST([NCURSESLIBS],[$NCURSES_LIBS])
+ AC_SUBST([CONF_LIB_NCURSES],[$ac_lib_ncurses])
+
++
+ dnl Checks for freetype
+ AC_ARG_ENABLE(
+ [freetype],
diff --git a/games-emulation/advancemame/files/advancemame-1.2-pic.patch b/games-emulation/advancemame/files/advancemame-pic.patch
index 049befbfac2c..049befbfac2c 100644
--- a/games-emulation/advancemame/files/advancemame-1.2-pic.patch
+++ b/games-emulation/advancemame/files/advancemame-pic.patch
diff --git a/games-emulation/advancemame/files/advancemame-1.2-verboselog.patch b/games-emulation/advancemame/files/advancemame-verboselog.patch
index b72c1224e75f..b72c1224e75f 100644
--- a/games-emulation/advancemame/files/advancemame-1.2-verboselog.patch
+++ b/games-emulation/advancemame/files/advancemame-verboselog.patch