summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-22 09:45:39 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-22 10:38:23 +0100
commite6fb38a072d5be219cf5eacea942f949113ff14d (patch)
treedb5152ba0e6068320f66f00b2a2c983a6f6b3331
parentdev-python/mkdocs-git-revision-date-localized-plugin: add missing PYTHON_USEDEP (diff)
downloadgentoo-e6fb38a072d5be219cf5eacea942f949113ff14d.tar.gz
gentoo-e6fb38a072d5be219cf5eacea942f949113ff14d.tar.bz2
gentoo-e6fb38a072d5be219cf5eacea942f949113ff14d.zip
dev-python/huawei-lte-api: Fix pycryptodome requirement
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/huawei-lte-api/huawei-lte-api-1.5.4-r1.ebuild (renamed from dev-python/huawei-lte-api/huawei-lte-api-1.5.4.ebuild)3
1 files changed, 2 insertions, 1 deletions
diff --git a/dev-python/huawei-lte-api/huawei-lte-api-1.5.4.ebuild b/dev-python/huawei-lte-api/huawei-lte-api-1.5.4-r1.ebuild
index 9f84cd2c71a0..e391e88edb3f 100644
--- a/dev-python/huawei-lte-api/huawei-lte-api-1.5.4.ebuild
+++ b/dev-python/huawei-lte-api/huawei-lte-api-1.5.4-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -21,6 +21,7 @@ RDEPEND="dev-python/pycryptodome[${PYTHON_USEDEP}]
python_prepare_all() {
# make cryptodome-friendly
+ sed -i -e 's:pycryptodomex:pycryptodome:' setup.py || die
find -name '*.py' -exec \
sed -i -e 's:Cryptodome:Crypto:g' {} + || die