summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-09 09:06:24 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-09 09:18:06 +0200
commite7070b6f4e4b718c7f636dde290f027256231744 (patch)
treea805cef66293e4aeb28478df4debefd14d415a11
parentdev-python/diskcache: Bump to 5.0.3 (diff)
downloadgentoo-e7070b6f.tar.gz
gentoo-e7070b6f.tar.bz2
gentoo-e7070b6f.zip
dev-python/sphinx-gallery: Bump to 0.8.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/sphinx-gallery/Manifest1
-rw-r--r--dev-python/sphinx-gallery/sphinx-gallery-0.8.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/sphinx-gallery/Manifest b/dev-python/sphinx-gallery/Manifest
index 2d5b1174649e..d3f2ab5fa1ed 100644
--- a/dev-python/sphinx-gallery/Manifest
+++ b/dev-python/sphinx-gallery/Manifest
@@ -1 +1,2 @@
DIST sphinx-gallery-0.3.1.tar.gz 88807 BLAKE2B 79218a1f438e2b8607c52b14f098c0136cb4d5ce15a12d82bdb3caf0c7c1090e7c4f210437fc660d8d4d19bf87bbaa2ec3c208d2dc8a77ad9deea5b5cefa3c05 SHA512 c51eaaef63a7496e223a4541d0560f694420b6ac4b2cde3779c405f0ab92d34aef7a37e4c41da9e59bd8a050c8d3eed330df3799e76a60ae35cdbc6f7c9cb8c1
+DIST sphinx-gallery-0.8.0.tar.gz 6501815 BLAKE2B ac4b131ea9395bc230e2bab57d3823951365828f7d56ec0317878014a349ebba02e372625551f033784f30788f7c1ed110a2ba901834c9cec7cd18fa0b7ae27f SHA512 8646dd903dc6006d9333d5c9e94d2ce3cdfdc97a84a009fc3fb7abca75b0b0428b9c186625d18eb5dbdb29649efbb82a567815e82d46712bc07b1be2d0e95f1a
diff --git a/dev-python/sphinx-gallery/sphinx-gallery-0.8.0.ebuild b/dev-python/sphinx-gallery/sphinx-gallery-0.8.0.ebuild
new file mode 100644
index 000000000000..4099672df38c
--- /dev/null
+++ b/dev-python/sphinx-gallery/sphinx-gallery-0.8.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx extension to automatically generate an examples gallery"
+HOMEPAGE="
+ https://sphinx-gallery.github.io/
+ https://github.com/sphinx-gallery/sphinx-gallery"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/joblib[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e 's:--cov-report= --cov=sphinx_gallery::' setup.cfg || die
+
+ # tests require internet
+ sed -e 's:test_embed_code_links_get_data:_&:' \
+ -i sphinx_gallery/tests/test_docs_resolv.py || die
+ sed -e 's:test_run_sphinx:_&:' \
+ -e 's:test_embed_links_and_styles:_&:' \
+ -i sphinx_gallery/tests/test_full.py || die
+
+ # TODO: the path is clearly wrong (/../.. <- leading slash)
+ sed -e 's:test_binder_logo_exists:_&:' \
+ -i sphinx_gallery/tests/test_full.py || die
+
+ distutils-r1_src_prepare
+}