summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2021-05-28 09:29:25 -0500
committerBen Kohler <bkohler@gentoo.org>2021-05-28 09:30:08 -0500
commite70d77e54a90ce6db5a18eb07c5979b1755ace1e (patch)
tree8dad287f8400bcac2d14f63997c577befe7f2039
parentsys-cluster/kops: initial import (diff)
downloadgentoo-e70d77e5.tar.gz
gentoo-e70d77e5.tar.bz2
gentoo-e70d77e5.zip
app-admin/xkcdpass: bump to 1.19.2
Package-Manager: Portage-3.0.19, Repoman-3.0.3 Signed-off-by: Ben Kohler <bkohler@gentoo.org>
-rw-r--r--app-admin/xkcdpass/Manifest1
-rw-r--r--app-admin/xkcdpass/xkcdpass-1.19.2.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/app-admin/xkcdpass/Manifest b/app-admin/xkcdpass/Manifest
index a3906de59d34..3c144143b7a7 100644
--- a/app-admin/xkcdpass/Manifest
+++ b/app-admin/xkcdpass/Manifest
@@ -1 +1,2 @@
DIST xkcdpass-1.17.6.tar.gz 8216233 BLAKE2B dc6f8b1bf76eba5271bf6027baf6bfbe5a18081ac85970ba35be3d0cf4e08d98d60b8bc819c05512aab94d621cf93fe9dca74a0108cdd4d94ad6ae830c28d3c2 SHA512 db47d6f0d5711e1aa4520fa3afb78b085b2e5a7599fa7eecbc3f806f5c7edceae9c54c250923147c87a837b54b5efd0d8f34f9c08e3104341f1243de0edf87f9
+DIST xkcdpass-1.19.2.tar.gz 2073808 BLAKE2B 19ad3f505ab672b1a2554e534896b15c77eb9741e7da01e22efff44d069ff6a482c122ec7fa616bc3789d2ce4bd5f6050c06bcff9661476d15fbc78edc505c36 SHA512 20376fc22fb4d251e2b921d4db48fea2109a4c42832614d41e807b262130111c58e01d1ded2019fad230a458953a2f185d92cfe95f3950aaa0a97750b3b3a2b6
diff --git a/app-admin/xkcdpass/xkcdpass-1.19.2.ebuild b/app-admin/xkcdpass/xkcdpass-1.19.2.ebuild
new file mode 100644
index 000000000000..904553903feb
--- /dev/null
+++ b/app-admin/xkcdpass/xkcdpass-1.19.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9,10} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="Password generator inspired by XKCD 936"
+HOMEPAGE="https://github.com/redacted/XKCD-password-generator"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD CC-BY-3.0
+ l10n_de? ( GPL-3 )
+ l10n_it? ( CC-BY-SA-3.0 )
+ l10n_no? ( CC-BY-4.0 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="l10n_de l10n_en l10n_es l10n_fi l10n_fr l10n_it l10n_no l10n_pt"
+
+src_prepare() {
+ default
+
+ use l10n_de || rm ${PN}/static/ger-anlx
+ use l10n_en || rm ${PN}/static/{eff-short,eff-special,legacy}
+ use l10n_es || rm ${PN}/static/spa-mich
+ use l10n_fi || rm ${PN}/static/fin-kotus
+ use l10n_fr || rm ${PN}/static/fr-*
+ use l10n_it || rm ${PN}/static/ita-wiki
+ use l10n_no || rm ${PN}/static/nor-nb
+ use l10n_pt || rm ${PN}/static/pt-*
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ doman ${PN}.1
+}