summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-17 09:23:24 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-17 10:30:56 +0200
commite715ecf79bd6e2d4eb77f6c4acce9fcb8d0d5055 (patch)
tree1fb6393570832ec52ebe052c2ba24983e5ebd32b
parentkde-apps/kolf: keyword 21.08.1 for ~riscv (diff)
downloadgentoo-e715ecf7.tar.gz
gentoo-e715ecf7.tar.bz2
gentoo-e715ecf7.zip
dev-python/pytest-rerunfailures: Bump to 10.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pytest-rerunfailures/Manifest1
-rw-r--r--dev-python/pytest-rerunfailures/pytest-rerunfailures-10.2.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/pytest-rerunfailures/Manifest b/dev-python/pytest-rerunfailures/Manifest
index e8b6e7e6eb6b..1c82a0dda3f0 100644
--- a/dev-python/pytest-rerunfailures/Manifest
+++ b/dev-python/pytest-rerunfailures/Manifest
@@ -1 +1,2 @@
DIST pytest-rerunfailures-10.1.tar.gz 13644 BLAKE2B 05b654128cbc94be803d15e038cdfcaa3879dbc43eb57dcf5cc3f5e52d0e4848a38b70048b32eb5afc99bcaec614abe6febfa95e4e8f7c7e07f6dc71dcdc3915 SHA512 9aa825c7fb1fb36edb78f1cdfc4a5f705e1688d00be0cd311e5cdf542698a2e03eed15b526235e2a35262000ce24923ea1049f3efa449c9a3723a2a5c1316717
+DIST pytest-rerunfailures-10.2.tar.gz 15863 BLAKE2B 9f317f3a39ac234e145a14d532d2727bb9fb5fead65c05372cf95268e0f589f9de994cd3c47e75dcb354c996595698c43fccdea5134d2e1921429c8ea7b71451 SHA512 8830610276e2cc172ee372ae4d8376bc6329138751ea2737a4def6af32d05c112c872a7a180ff554018058c05ed0d109927dbac61f748586257e40b0243f03c8
diff --git a/dev-python/pytest-rerunfailures/pytest-rerunfailures-10.2.ebuild b/dev-python/pytest-rerunfailures/pytest-rerunfailures-10.2.ebuild
new file mode 100644
index 000000000000..369054f3e717
--- /dev/null
+++ b/dev-python/pytest-rerunfailures/pytest-rerunfailures-10.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="pytest plugin to re-run tests to eliminate flaky failures"
+HOMEPAGE="https://pypi.org/project/pytest-rerunfailures/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MPL-2.0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="
+ >=dev-python/pytest-5.0[${PYTHON_USEDEP}]
+ test? ( !!dev-python/flaky )
+"
+
+distutils_enable_tests pytest