summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@atlas.cz>2023-02-27 17:22:51 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-27 18:59:34 +0100
commite72cfc62783554f9cea215b89bd21f3acec4553e (patch)
tree565fc0043be45cfccd664db8151849d47be484ce
parentdev-python/python-gammu: enable py3.11 (diff)
downloadgentoo-e72cfc62.tar.gz
gentoo-e72cfc62.tar.bz2
gentoo-e72cfc62.zip
app-text/pytextile: add 4.0.2
- EAPI bump to 8 - convert to PEP517 - enable py3.11 Closes: https://bugs.gentoo.org/896640 Signed-off-by: Petr Vaněk <arkamar@atlas.cz> Closes: https://github.com/gentoo/gentoo/pull/29836 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--app-text/pytextile/Manifest1
-rw-r--r--app-text/pytextile/pytextile-4.0.2.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/app-text/pytextile/Manifest b/app-text/pytextile/Manifest
index 08cfb9abe240..e3a71b9a187f 100644
--- a/app-text/pytextile/Manifest
+++ b/app-text/pytextile/Manifest
@@ -1 +1,2 @@
DIST pytextile-4.0.1.tar.gz 49282 BLAKE2B b51220ff33fe43b83d0aefee840b5170747015073fbe88934798c2505c3455e9805eee8815ec8068521c88a44a309bd0eb32e84757d088536f1c12a1f9bc0ca0 SHA512 e299663fd71b935e9c948649baba80584b1339dd3393a3f37b39475fe1d6a4addaaa2adcd16ba57b4c5db43ab9f8de6e9332871915b1fff7b7882ad5e8d64580
+DIST python-textile-4.0.2.gh.tar.gz 49296 BLAKE2B e9ac36b0ecf401a07aea1037c1f4390e440123d7e16f8fef64c257d27f6ef9c6918018ff34e9f8ad367767f3ebc5ce7957be424b2e6dac62fe8a1f7736b8eff7 SHA512 eb59e44b9a8521bcfa98f476e23efd727ffd867277d24f102bbb9511a99a0d636c324e22f8562382074007f304490c4ec6a5fde529f41b15f055a9cf16d49b8e
diff --git a/app-text/pytextile/pytextile-4.0.2.ebuild b/app-text/pytextile/pytextile-4.0.2.ebuild
new file mode 100644
index 000000000000..e0c784fe396a
--- /dev/null
+++ b/app-text/pytextile/pytextile-4.0.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+MY_P="python-textile-${PV}"
+DESCRIPTION="A Python port of Textile, A humane web text generator"
+HOMEPAGE="
+ https://github.com/textile/python-textile/
+ https://pypi.org/project/textile/
+"
+SRC_URI="
+ https://github.com/textile/python-textile/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ dev-python/regex[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # tests that need network access
+ tests/test_getimagesize.py
+ tests/test_imagesize.py
+ tests/test_textile.py
+ )
+ epytest -o addopts=
+}