summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-11-21 11:53:21 +0100
committerLars Wendler <polynomial-c@gentoo.org>2018-11-21 11:54:26 +0100
commite733bac105ec79e7ef2d9bc1bb820f2a884d0426 (patch)
tree9892f8200b83bdec9641c67dabbeffb6b89c9e67
parentwww-client/vivaldi: Old (diff)
downloadgentoo-e733bac1.tar.gz
gentoo-e733bac1.tar.bz2
gentoo-e733bac1.zip
app-arch/star: Revbump to add dependency on sys-libs/libcap
Also bumped ebuild to EAPI-7 Bumped straight to stable. Closes: https://bugs.gentoo.org/628070 Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--app-arch/star/star-1.5.3-r1.ebuild (renamed from app-arch/star/star-1.5.3.ebuild)22
1 files changed, 16 insertions, 6 deletions
diff --git a/app-arch/star/star-1.5.3.ebuild b/app-arch/star/star-1.5.3-r1.ebuild
index f841e026ddc1..480ce97a4327 100644
--- a/app-arch/star/star-1.5.3.ebuild
+++ b/app-arch/star/star-1.5.3-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="An enhanced (world's fastest) tar, as well as enhanced mt/rmt"
HOMEPAGE="http://s-tar.sourceforge.net/"
@@ -15,13 +15,16 @@ KEYWORDS="alpha amd64 hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-linux ~x86-linu
IUSE="acl xattr"
DEPEND="
+ sys-libs/libcap
acl? ( sys-apps/acl )
xattr? ( sys-apps/attr )"
RDEPEND="${DEPEND}"
-S=${WORKDIR}/${P/_alpha[0-9][0-9]}
+S="${WORKDIR}/${P/_alpha[0-9][0-9]}"
src_prepare() {
+ default
+
find -type f -exec chmod -c u+w '{}' + || die
sed \
-e "s:/opt/schily:${EPREFIX}/usr:g" \
@@ -33,15 +36,21 @@ src_prepare() {
if use acl; then
sed \
-e 's:[$]ac_cv_header_sys_acl_h:disable acl:' \
- -i "${S}/autoconf/configure" || die
+ -i autoconf/configure || die
fi
if use xattr; then
sed \
-e 's:[$]ac_cv_header_attr_xattr_h:disable xattr:' \
- -i "${S}/autoconf/configure" || die
+ -i autoconf/configure || die
fi
+ # "echo -n" is not POSIX compliant
+ sed \
+ -e 's@echo $ac_n@printf@' \
+ -e '/printf/s@$ac_c@@g' \
+ -i autoconf/configure || die
+
# Create additional symlinks needed for some archs.
pushd "${S}/RULES" > /dev/null
local t
@@ -56,6 +65,7 @@ src_configure() { :; } #avoid ./configure run
src_compile() {
emake \
+ GMAKE_NOWARN="true" \
CC="$(tc-getCC)" \
COPTX="${CFLAGS}" \
CPPOPTX="${CPPFLAGS}" \