summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-08 05:32:40 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-08 06:40:27 +0100
commite73e5efc3b76e0050fe21d36806b39ed89485c52 (patch)
tree96d2165fd25dd27cd467539713881aa8224a0845
parentdev-python/trimesh: Bump to 4.1.8 (diff)
downloadgentoo-e73e5efc.tar.gz
gentoo-e73e5efc.tar.bz2
gentoo-e73e5efc.zip
dev-python/argcomplete: Bump to 3.2.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/argcomplete/Manifest1
-rw-r--r--dev-python/argcomplete/argcomplete-3.2.3.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/argcomplete/Manifest b/dev-python/argcomplete/Manifest
index af646db4b778..e1933ed6bac7 100644
--- a/dev-python/argcomplete/Manifest
+++ b/dev-python/argcomplete/Manifest
@@ -1 +1,2 @@
DIST argcomplete-3.2.2.tar.gz 80764 BLAKE2B 0e059439c64301026fd238b070adb84f69c81f2f8fe6e27d31426abb71d4fadf8b34ff84465d9a9f5757550f6f55330ab17e204b7be18b459cddfb06c3851e25 SHA512 dd94795c561a692286341be234cd15ae684f0af6b11475322e6d616e640c27e7c9d9c73686790cecc09535b7f1287f95be2faa8b62329b12a6dbf9e2d403e439
+DIST argcomplete-3.2.3.tar.gz 81130 BLAKE2B 1c3a1c3fe9159ba1ab64db2a05d32dd961b08bb00d4cf3015fbb7990c02ebb766200fabe228c4e48ad791ea1a02db0775df1eec3181c7d1291743894e986f61c SHA512 25c73ec01a9c7e0b3d2cab1b86953369b0464431e86d6be2ba14d0209c1e1bc9fe5c5ce02590d86a44df74c9e828d4579b1265d2a37adf21f1e8bfdfb2350a44
diff --git a/dev-python/argcomplete/argcomplete-3.2.3.ebuild b/dev-python/argcomplete/argcomplete-3.2.3.ebuild
new file mode 100644
index 000000000000..0ea9deb31943
--- /dev/null
+++ b/dev-python/argcomplete/argcomplete-3.2.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Bash tab completion for argparse"
+HOMEPAGE="
+ https://github.com/kislyuk/argcomplete/
+ https://pypi.org/project/argcomplete/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# pip is called as an external tool
+BDEPEND="
+ test? (
+ app-shells/fish
+ app-shells/tcsh
+ app-shells/zsh
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ >=dev-python/pip-19
+ )
+"
+
+PATCHES=(
+ # increase test timeouts -- this is particularly necessary
+ # for entry point tests because they read metadata of all installed
+ # packages which can take real long on systems with lots of packages
+ "${FILESDIR}/argcomplete-3.1.6-timeout.patch"
+)
+
+python_test() {
+ "${EPYTHON}" test/test.py -v || die
+}