summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRahil Bhimjiani <rahil3108@gmail.com>2023-11-13 18:17:16 +0530
committerYixun Lan <dlan@gentoo.org>2023-11-14 02:25:37 +0000
commite7664c77a7cf883ee474afeb91c5f6d8965064ff (patch)
treeb8a98e92c4c280609a1926217ac456b2c38e7515
parentsci-mathematics/polymake: re-enable the test suite (diff)
downloadgentoo-e7664c77a7cf883ee474afeb91c5f6d8965064ff.tar.gz
gentoo-e7664c77a7cf883ee474afeb91c5f6d8965064ff.tar.bz2
gentoo-e7664c77a7cf883ee474afeb91c5f6d8965064ff.zip
app-containers/podman-tui: add 0.12.0
1) split LICENSE Closes: https://github.com/gentoo/gentoo/pull/33786 Signed-off-by: Rahil Bhimjiani <rahil3108@gmail.com> Signed-off-by: Yixun Lan <dlan@gentoo.org>
-rw-r--r--app-containers/podman-tui/Manifest1
-rw-r--r--app-containers/podman-tui/podman-tui-0.12.0.ebuild37
-rw-r--r--app-containers/podman-tui/podman-tui-9999.ebuild7
3 files changed, 43 insertions, 2 deletions
diff --git a/app-containers/podman-tui/Manifest b/app-containers/podman-tui/Manifest
index 165d9ec746e2..78ce51b6a1e3 100644
--- a/app-containers/podman-tui/Manifest
+++ b/app-containers/podman-tui/Manifest
@@ -1 +1,2 @@
DIST podman-tui-0.11.0.tar.gz 13317542 BLAKE2B 0492799b7e61eaa75344392d824be6f41bac0b61510587cca936ec2e5f516e2513e709d739e66cd86a658fa916f61a02dbf0802a3761bab2ccb11705c3d514f3 SHA512 1b5ce216829a0f2ef345920ea908a5f721ee704bf3c7efe121e42c413edb84fb247eb32964fcd7928c734df93efd85a3c1fb5a92b0e6f3c1de3b4906fbc77fe2
+DIST podman-tui-0.12.0.tar.gz 15740756 BLAKE2B 2d38997e6ffc67d8d4f2e8c68856b4da4eb3b658ab5998da752b5d01a7d7591d3f196efba11f9d6d67bf438335729ea7bcab920eb1e2e847f6a024c3f4b3ebed SHA512 753932fef58746c80752c142aae17ef61b4632af51f8d9bd5aee29246ffc8179f98f4e38c7607a82efd25d0b809e9065a5b537b1a3a823eabae23a87b5b6dd74
diff --git a/app-containers/podman-tui/podman-tui-0.12.0.ebuild b/app-containers/podman-tui/podman-tui-0.12.0.ebuild
new file mode 100644
index 000000000000..2effb9e6c06b
--- /dev/null
+++ b/app-containers/podman-tui/podman-tui-0.12.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+DESCRIPTION="Terminal UI frontend for Podman"
+HOMEPAGE="https://github.com/containers/podman-tui"
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/containers/podman-tui.git"
+else
+ SRC_URI="https://github.com/containers/podman-tui/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+# main pkg
+LICENSE="Apache-2.0"
+# deps
+LICENSE+=" BSD-2 BSD MIT MPL-2.0"
+SLOT="0"
+RESTRICT="test"
+RDEPEND="
+ >=app-containers/podman-4.0.2
+"
+
+src_compile() {
+ # parse tags from Makefile & make them comma-seperated as space-seperated list is deprecated
+ local BUILDTAGS=$(grep 'BUILDTAGS :=' Makefile | awk -F\" '{ print $2; }' | sed -e 's| |,|g;')
+ ego build -tags "${BUILDTAGS}"
+}
+
+src_install() {
+ dobin "${PN}"
+ einstalldocs
+}
diff --git a/app-containers/podman-tui/podman-tui-9999.ebuild b/app-containers/podman-tui/podman-tui-9999.ebuild
index 58c2601964d0..2effb9e6c06b 100644
--- a/app-containers/podman-tui/podman-tui-9999.ebuild
+++ b/app-containers/podman-tui/podman-tui-9999.ebuild
@@ -7,7 +7,7 @@ inherit go-module
DESCRIPTION="Terminal UI frontend for Podman"
HOMEPAGE="https://github.com/containers/podman-tui"
-if [[ ${PV} == *9999* ]]; then
+if [[ ${PV} == 9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/containers/podman-tui.git"
else
@@ -15,7 +15,10 @@ else
KEYWORDS="~amd64"
fi
-LICENSE="Apache-2.0 BSD-2 BSD MIT MPL-2.0"
+# main pkg
+LICENSE="Apache-2.0"
+# deps
+LICENSE+=" BSD-2 BSD MIT MPL-2.0"
SLOT="0"
RESTRICT="test"
RDEPEND="