summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSlawomir Lis <slis@gentoo.org>2019-08-30 06:36:52 +0200
committerSlawomir Lis <slis@gentoo.org>2019-08-30 07:08:25 +0200
commite7773552b82db1a5b7a10fbf9f5c86d77a0b2e8b (patch)
treecc95584a8bd84cf884e37bd22b7da190c574b321
parentapp-text/calibre: Bump to version 3.47.0 (diff)
downloadgentoo-e7773552.tar.gz
gentoo-e7773552.tar.bz2
gentoo-e7773552.zip
dev-libs/libflatarray: added version 0.2.0
This version is required to build libgeodecomp, latest one seems not to be supported yet. Package-Manager: Portage-2.3.73, Repoman-2.3.17 Signed-off-by: Slawek Lis <slis@gentoo.org>
-rw-r--r--dev-libs/libflatarray/Manifest1
-rw-r--r--dev-libs/libflatarray/libflatarray-0.2.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-libs/libflatarray/Manifest b/dev-libs/libflatarray/Manifest
index 40387084ff3b..af1a157d02f1 100644
--- a/dev-libs/libflatarray/Manifest
+++ b/dev-libs/libflatarray/Manifest
@@ -1 +1,2 @@
+DIST libflatarray-0.2.0.tar.bz2 34193 BLAKE2B 8f409b097a0dfe037e9fdd1f8ed3b0ba86ef9ab816219b9357d119afa1c7236c0a467d9705fd5050ccbdc54ee40b811d2daee0a697f8ba720f037294d0305d52 SHA512 96050c08479429baf22a9694ca7354e1ab4fa892976d4098419e2863cac8e21aec586116a1702a5050753febd9b9321a14fc4da5d6487cf75a574562ec4d4647
DIST libflatarray-0.3.0.tar.bz2 104544 BLAKE2B 9ac490a526fbd71478ac569538bad28e01a1a91bd71d37e85bf89181e856e79b2dec6af5415f238e5f72fbbe57cda59ee87ebd79cd273887061e2bbb93a7ce31 SHA512 c58339cdadf98f552d2f1b440a293c48923f32fc43a5a06ee8b8a40835a5f6c21514f7a9efa0ff23930ab9fdda8d4389641ec83c589e1982dbf5a3f75d2ffd37
diff --git a/dev-libs/libflatarray/libflatarray-0.2.0.ebuild b/dev-libs/libflatarray/libflatarray-0.2.0.ebuild
new file mode 100644
index 000000000000..35250d070a6f
--- /dev/null
+++ b/dev-libs/libflatarray/libflatarray-0.2.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils cuda
+
+SRC_URI="http://www.libgeodecomp.org/archive/${P}.tar.bz2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DESCRIPTION="Struct of arrays library with object oriented interface for C++"
+HOMEPAGE="http://www.libgeodecomp.org/libflatarray.html"
+
+SLOT="0"
+LICENSE="Boost-1.0"
+IUSE="cuda doc"
+
+DEPEND="
+ doc? ( app-doc/doxygen )
+ cuda? ( dev-util/nvidia-cuda-toolkit )"
+
+src_prepare() {
+ cmake-utils_src_prepare
+ use cuda && cuda_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_CUDA=$(usex cuda)
+ -DWITH_SILO=false
+ )
+ cmake-utils_src_configure
+}