summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2019-10-17 12:31:35 +0200
committerUlrich Müller <ulm@gentoo.org>2019-10-17 15:18:41 +0200
commite7884eaa37357edcb54d1c29bc6b06c8e4f0dd21 (patch)
tree22c705c9c7a66148093fa2e0a44d78040c1a9dc6
parentlicenses: Remove unused yuuji license. (diff)
downloadgentoo-e7884eaa37357edcb54d1c29bc6b06c8e4f0dd21.tar.gz
gentoo-e7884eaa37357edcb54d1c29bc6b06c8e4f0dd21.tar.bz2
gentoo-e7884eaa37357edcb54d1c29bc6b06c8e4f0dd21.zip
app-emacs/mpg123-el: Bump to version 1.61.
Package-Manager: Portage-2.3.77, Repoman-2.3.17 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
-rw-r--r--app-emacs/mpg123-el/Manifest1
-rw-r--r--app-emacs/mpg123-el/mpg123-el-1.61.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/app-emacs/mpg123-el/Manifest b/app-emacs/mpg123-el/Manifest
index 738e74811963..d88ed01e1db1 100644
--- a/app-emacs/mpg123-el/Manifest
+++ b/app-emacs/mpg123-el/Manifest
@@ -1,2 +1,3 @@
DIST mpg123-el-1.59.tar.xz 34076 BLAKE2B ddfd5940665fb11e692958332d1e53cb5adf3e36bd1d178b764ceb2b1a34928fc37ec843e8e1d10d22c9efe4b5de863797be3b3a527d28fad5081ee682ff1d4b SHA512 48fae024529be7b88553fc43fb626253f3d3a10d6709378a565a0d407374569e5573e52c0b26abc4d6f2f51ad7f680d655a1ac15ff696f4534c39a9a3536bc0e
DIST mpg123-el-1.60.tar.xz 34104 BLAKE2B f48a0ce460ee382b261accaf2188bb1dde7b17b1b09766cda7ef69f92d3e022a4390a7c9e9a97085f1c1e87377d114bcbdb29de512438ee3652baa0be0b413a7 SHA512 5f4d7aefeaec6c5e94dcd5d15af7d0b89dc79274dce117309a70170cd0ec8cafac7c275518ea21d797d9251c31033b93c0581f26f83792c7b697094f4b194611
+DIST mpg123-el-1.61.tar.xz 34216 BLAKE2B 3f0f85bbf0f5854b899aefb443f9b2b011dd5dd85c815fc8be723bade93be805b121e952cab3c56a3897bed41fa65988331c004537e565abcb660b6dd402a0c5 SHA512 96b50a8fc945c6811bce7b8cfa28fe235f2d2ddf9cbd1904c94f272f6df13a991761dbb4f186c1bda04720fb50115515361dbff4838e7623261719f2ecc6698e
diff --git a/app-emacs/mpg123-el/mpg123-el-1.61.ebuild b/app-emacs/mpg123-el/mpg123-el-1.61.ebuild
new file mode 100644
index 000000000000..eeba80891947
--- /dev/null
+++ b/app-emacs/mpg123-el/mpg123-el-1.61.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit elisp toolchain-funcs
+
+DESCRIPTION="Emacs front-end to mpg123 audio player and OggVorbis audio player"
+HOMEPAGE="http://www.gentei.org/~yuuji/software/mpg123el/"
+SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.tar.xz"
+
+LICENSE="mpg123-el"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="media-sound/mpg123
+ media-sound/alsa-utils"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ $(tc-getCC) ${CFLAGS} ${CPPFLAGS} ${LDFLAGS} -o tagput tagput.c || die
+ $(tc-getCC) ${CFLAGS} ${CPPFLAGS} ${LDFLAGS} -o id3put id3put.c || die
+ elisp-compile *.el
+}
+
+src_install() {
+ dobin tagput id3put
+ elisp-install ${PN} *.el *.elc
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+}