summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-20 19:51:31 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-20 20:21:21 +0100
commite78a1cb6017b61b9381725d325ac90d995cdf55d (patch)
tree860daf0999d80cf2a7cbe87113ef7f730f564463
parentdev-python/unearth: Bump to 0.15.0 (diff)
downloadgentoo-e78a1cb6017b61b9381725d325ac90d995cdf55d.tar.gz
gentoo-e78a1cb6017b61b9381725d325ac90d995cdf55d.tar.bz2
gentoo-e78a1cb6017b61b9381725d325ac90d995cdf55d.zip
dev-python/uvicorn: Bump to 0.29.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/uvicorn/Manifest1
-rw-r--r--dev-python/uvicorn/uvicorn-0.29.0.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/dev-python/uvicorn/Manifest b/dev-python/uvicorn/Manifest
index 31330cad6e86..28c81799e9e8 100644
--- a/dev-python/uvicorn/Manifest
+++ b/dev-python/uvicorn/Manifest
@@ -1,3 +1,4 @@
DIST uvicorn-0.27.1.gh.tar.gz 718990 BLAKE2B a520bcb2cde4ed6125c0d64b06d3d301471c1722f7642adb09320b6a6386fe6206a501f171ed4bfe4f95f333c323d1e9f65efc89c1669abc398a57ad0ad27b16 SHA512 57946b71e3f332a9c549ec48ea25375d5ddad4e7f0d5b406690569ed492c305d8441b3ded5386d6d3295e62007cfcd2ae2f0816266cf493391e813db3ef44109
DIST uvicorn-0.28.0.gh.tar.gz 718359 BLAKE2B a8e08c3abe6ea1e9d596ad57ef6d0efa0b219bdba89eb27aa6c7f6efa383cc2edfc2d755b8fb58f84d8eb5307fb33ca6c5c15cf2f4de361ee5dbb81cb6b2e897 SHA512 7e001e4d40092f9cc6f230f53958f71150ab6818ab883cd7edfe4a2b7269d5d17ce98d3b279e74b9b58026bcef9b48d1944405df253cfaf18b943979f1a1835d
DIST uvicorn-0.28.1.gh.tar.gz 718292 BLAKE2B cfa9284d941cb8817968d6e65c1cf62cee59398b9674785f183465abda544b8ea2d83e8791cf357ee736636bd9a00ddd29b0209d1ca94170d2d2130404b20f18 SHA512 5ce75daee19d20b4ffdc653cd7d271b3f1776f1f350da1b41a627fd3210bee620610c0c17d0e735c8a4fe883fb1bc72e603fb9dcd1939b6cd797c3b1800bf75e
+DIST uvicorn-0.29.0.gh.tar.gz 719202 BLAKE2B 15a1e9d001e00805d9efe89c1b46416f6556d944ec5a32fb31c8368d4c0e1e32155169e9b5754c7d56a3ee86a1b7edddcf0d9a641abf74fdb89c1332ebd289af SHA512 bb37940acc2eba2a649d07ba44890400332e5ad873ac03c6740c1bc730068ede39c2e6d9aefb0f100ec261d7ed2eef1596c99a060fd8000cff874b25bdbbbdfa
diff --git a/dev-python/uvicorn/uvicorn-0.29.0.ebuild b/dev-python/uvicorn/uvicorn-0.29.0.ebuild
new file mode 100644
index 000000000000..5950d3bc0878
--- /dev/null
+++ b/dev-python/uvicorn/uvicorn-0.29.0.ebuild
@@ -0,0 +1,75 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Lightning-fast ASGI server implementation"
+HOMEPAGE="
+ https://www.uvicorn.org/
+ https://github.com/encode/uvicorn/
+ https://pypi.org/project/uvicorn/
+"
+# as of 0.28.0, no tests in sdist
+SRC_URI="
+ https://github.com/encode/uvicorn/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="test-rust"
+
+RDEPEND="
+ >=dev-python/asgiref-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/click-7.0[${PYTHON_USEDEP}]
+ >=dev-python/h11-0.8[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/typing-extensions-4.0[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ test? (
+ dev-python/a2wsgi[${PYTHON_USEDEP}]
+ dev-python/httpx[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/python-dotenv[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/websockets-10.4[${PYTHON_USEDEP}]
+ dev-python/wsproto[${PYTHON_USEDEP}]
+ test-rust? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ dev-python/watchfiles[${PYTHON_USEDEP}]
+ )
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # too long path for unix socket
+ tests/test_config.py::test_bind_unix_socket_works_with_reload_or_workers
+ )
+ case ${EPYTHON} in
+ pypy3)
+ # TODO
+ EPYTEST_DESELECT+=(
+ tests/middleware/test_logging.py::test_running_log_using_fd
+ )
+ ;;
+ esac
+
+ epytest
+}
+
+pkg_postinst() {
+ optfeature "auto reload on file changes" dev-python/watchfiles
+}