summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-09-12 19:55:04 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-09-12 19:55:04 +0300
commite78a681d767b22dfd92c5790348742ca871c8bc6 (patch)
tree339cf3eb9c173a55bba1148666681a7210e0da52
parentdev-python/rencode: import fix CVE-2021-40839 (diff)
downloadgentoo-e78a681d767b22dfd92c5790348742ca871c8bc6.tar.gz
gentoo-e78a681d767b22dfd92c5790348742ca871c8bc6.tar.bz2
gentoo-e78a681d767b22dfd92c5790348742ca871c8bc6.zip
dev-python/rjsmin: enable py3.10, EAPI=8, enable tests
Closes: https://bugs.gentoo.org/797856 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/rjsmin/Manifest2
-rw-r--r--dev-python/rjsmin/rjsmin-1.1.0.ebuild12
2 files changed, 9 insertions, 5 deletions
diff --git a/dev-python/rjsmin/Manifest b/dev-python/rjsmin/Manifest
index c217598e1992..93f4f5a06c5d 100644
--- a/dev-python/rjsmin/Manifest
+++ b/dev-python/rjsmin/Manifest
@@ -1 +1 @@
-DIST rjsmin-1.1.0.tar.gz 412426 BLAKE2B ac4aed389359b27c6506890da8ec7874536835befff6868b556542489deaadb5557caf688fd959cd2dff1b25d312a8b738ea5f73e00fbb1f705ddeeaea021dd2 SHA512 e89641666f4235e5125e33a8da727a204bd0f263c101833849d8368edb7522a184b0f6d87da39690b7e8c1dad0ae8a40508b019e971393a3ad99440ad8ccc3fc
+DIST rjsmin-1.1.0.gh.tar.gz 437054 BLAKE2B 83b24f1ee94ded66a70ed75b3e494b3e6948edf82fecc80f261964fd2bb032a8cb496ed919f461131b3381c402a6397e65bfa5031f46691c4badfc5e9e2faea2 SHA512 5e168e51e1716fe35a3520fba828d721638094a6f6f73deb4c49183d8cd51531131962e2c7092ada092da63c4ddd615215088bd1a9e474d508f80dc0603d3118
diff --git a/dev-python/rjsmin/rjsmin-1.1.0.ebuild b/dev-python/rjsmin/rjsmin-1.1.0.ebuild
index 2b5672966bbb..ef45a0bd23f0 100644
--- a/dev-python/rjsmin/rjsmin-1.1.0.ebuild
+++ b/dev-python/rjsmin/rjsmin-1.1.0.ebuild
@@ -1,15 +1,19 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="Javascript minifier written in python."
HOMEPAGE="http://opensource.perlig.de/rjsmin/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="
+ https://github.com/ndparker/rjsmin/archive/${PV}.tar.gz -> ${P}.gh.tar.gz
+"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64"
+
+distutils_enable_tests pytest