summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-09-05 09:08:45 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-09-05 09:10:56 +0100
commite790d862c726d8910aa37f9ed63a02a05f57cfea (patch)
treecb31c4820594648655becf112e22b599a28c2f28
parentprofiles/package.mask: remove obsolete mask (diff)
downloadgentoo-e790d862.tar.gz
gentoo-e790d862.tar.bz2
gentoo-e790d862.zip
dev-lang/ghc: make USE=binary and USE=profile mutually exclusive
We prebuild binaries without profiling support in Gentoo. Reported-by: Toralf Förster Closes: https://bugs.gentoo.org/740236 Package-Manager: Portage-3.0.5, Repoman-3.0.1 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
-rw-r--r--dev-lang/ghc/ghc-8.10.1.ebuild6
-rw-r--r--dev-lang/ghc/ghc-8.8.3.ebuild6
-rw-r--r--dev-lang/ghc/ghc-8.8.4.ebuild6
3 files changed, 15 insertions, 3 deletions
diff --git a/dev-lang/ghc/ghc-8.10.1.ebuild b/dev-lang/ghc/ghc-8.10.1.ebuild
index 7845cce005cc..9749ccd0b25d 100644
--- a/dev-lang/ghc/ghc-8.10.1.ebuild
+++ b/dev-lang/ghc/ghc-8.10.1.ebuild
@@ -113,7 +113,11 @@ DEPEND="${RDEPEND}
>=dev-libs/libxslt-1.1.2 )
!ghcbootstrap? ( ${PREBUILT_BINARY_DEPENDS} )"
-REQUIRED_USE="?? ( ghcbootstrap binary )"
+# we build binaries without profiling support
+REQUIRED_USE="
+ ?? ( ghcbootstrap binary )
+ ?? ( profile binary )
+"
# haskell libraries built with cabal in configure mode, #515354
QA_CONFIGURE_OPTIONS+=" --with-compiler --with-gcc"
diff --git a/dev-lang/ghc/ghc-8.8.3.ebuild b/dev-lang/ghc/ghc-8.8.3.ebuild
index 169068559531..f59a40a4139e 100644
--- a/dev-lang/ghc/ghc-8.8.3.ebuild
+++ b/dev-lang/ghc/ghc-8.8.3.ebuild
@@ -112,7 +112,11 @@ DEPEND="${RDEPEND}
>=dev-libs/libxslt-1.1.2 )
!ghcbootstrap? ( ${PREBUILT_BINARY_DEPENDS} )"
-REQUIRED_USE="?? ( ghcbootstrap binary )"
+# we build binaries without profiling support
+REQUIRED_USE="
+ ?? ( ghcbootstrap binary )
+ ?? ( profile binary )
+"
# haskell libraries built with cabal in configure mode, #515354
QA_CONFIGURE_OPTIONS+=" --with-compiler --with-gcc"
diff --git a/dev-lang/ghc/ghc-8.8.4.ebuild b/dev-lang/ghc/ghc-8.8.4.ebuild
index 9ada4d7c1c10..5d1674fac8d9 100644
--- a/dev-lang/ghc/ghc-8.8.4.ebuild
+++ b/dev-lang/ghc/ghc-8.8.4.ebuild
@@ -112,7 +112,11 @@ DEPEND="${RDEPEND}
>=dev-libs/libxslt-1.1.2 )
!ghcbootstrap? ( ${PREBUILT_BINARY_DEPENDS} )"
-REQUIRED_USE="?? ( ghcbootstrap binary )"
+# we build binaries without profiling support
+REQUIRED_USE="
+ ?? ( ghcbootstrap binary )
+ ?? ( profile binary )
+"
# haskell libraries built with cabal in configure mode, #515354
QA_CONFIGURE_OPTIONS+=" --with-compiler --with-gcc"