summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2016-12-23 19:20:03 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2016-12-23 19:20:40 +0000
commite7b23d8f7f6b6d140360fe27f7a388b5e61e138a (patch)
tree1312bbf2e84b16616115a82210cbf3557b9b445f
parentnet-misc/freerdp: new snapshot (diff)
downloadgentoo-e7b23d8f.tar.gz
gentoo-e7b23d8f.tar.bz2
gentoo-e7b23d8f.zip
media-libs/aalib: add epatch_user, fix implicit function declarations on gcc-6
Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--media-libs/aalib/aalib-1.4_rc5-r8.ebuild71
-rw-r--r--media-libs/aalib/files/aalib-1.4_rc5-key-down-OOB.patch (renamed from media-libs/aalib/files/aalib-1.4_rc6-key-down-OOB.patch)0
-rw-r--r--media-libs/aalib/files/aalib-1.4_rc5-more-protos.patch55
3 files changed, 126 insertions, 0 deletions
diff --git a/media-libs/aalib/aalib-1.4_rc5-r8.ebuild b/media-libs/aalib/aalib-1.4_rc5-r8.ebuild
new file mode 100644
index 000000000000..bfc4f248b709
--- /dev/null
+++ b/media-libs/aalib/aalib-1.4_rc5-r8.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-multilib eutils toolchain-funcs
+
+MY_P="${P/_/}"
+S="${WORKDIR}/${PN}-1.4.0"
+
+DESCRIPTION="A ASCII-Graphics Library"
+HOMEPAGE="http://aa-project.sourceforge.net/aalib/"
+SRC_URI="mirror://sourceforge/aa-project/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="X slang gpm static-libs"
+
+RDEPEND="
+ X? ( >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}] )
+ gpm? ( >=sys-libs/gpm-1.20.7-r2[${MULTILIB_USEDEP}] )
+ slang? ( >=sys-libs/slang-2.2.4-r1[${MULTILIB_USEDEP}] )
+ >=sys-libs/ncurses-5.9-r3:0=[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ X? ( x11-proto/xproto )
+"
+
+DOCS="ANNOUNCE AUTHORS ChangeLog NEWS README*"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.4_rc4-gentoo.patch
+ epatch "${FILESDIR}"/${PN}-1.4_rc4-m4.patch
+ epatch "${FILESDIR}"/${PN}-1.4_rc5-fix-protos.patch #224267
+ epatch "${FILESDIR}"/${PN}-1.4_rc5-fix-aarender.patch #214142
+ epatch "${FILESDIR}"/${PN}-1.4_rc5-tinfo.patch #468566
+ epatch "${FILESDIR}"/${PN}-1.4_rc5-key-down-OOB.patch
+ epatch "${FILESDIR}"/${PN}-1.4_rc5-more-protos.patch
+
+ sed -i -e 's:#include <malloc.h>:#include <stdlib.h>:g' "${S}"/src/*.c
+
+ # Fix bug #165617.
+ use gpm || sed -i \
+ 's/gpm_mousedriver_test=yes/gpm_mousedriver_test=no/' "${S}/configure.in"
+
+ #467988 automake-1.13
+ mv configure.{in,ac} || die
+ sed -i 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/g' configure.ac || die
+
+ epatch_user
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with slang slang-driver)
+ $(use_with X x11-driver)
+ $(use_enable static-libs static)
+ )
+
+ PKG_CONFIG=$(tc-getPKG_CONFIG) \
+ autotools-multilib_src_configure
+}
+
+src_install() {
+ autotools-multilib_src_install
+ use static-libs || prune_libtool_files --all
+}
diff --git a/media-libs/aalib/files/aalib-1.4_rc6-key-down-OOB.patch b/media-libs/aalib/files/aalib-1.4_rc5-key-down-OOB.patch
index 8078aa5b2708..8078aa5b2708 100644
--- a/media-libs/aalib/files/aalib-1.4_rc6-key-down-OOB.patch
+++ b/media-libs/aalib/files/aalib-1.4_rc5-key-down-OOB.patch
diff --git a/media-libs/aalib/files/aalib-1.4_rc5-more-protos.patch b/media-libs/aalib/files/aalib-1.4_rc5-more-protos.patch
new file mode 100644
index 000000000000..58d37f1cb7c9
--- /dev/null
+++ b/media-libs/aalib/files/aalib-1.4_rc5-more-protos.patch
@@ -0,0 +1,55 @@
+diff --git a/src/aakbdreg.c b/src/aakbdreg.c
+index f4f8efb..b344dd8 100644
+--- a/src/aakbdreg.c
++++ b/src/aakbdreg.c
+@@ -1,2 +1,3 @@
+ #include <stdlib.h>
++#include <string.h> /* strcmp */
+ #include "config.h"
+diff --git a/src/aalinuxkbd.c b/src/aalinuxkbd.c
+index a5379bb..e816eb2 100644
+--- a/src/aalinuxkbd.c
++++ b/src/aalinuxkbd.c
+@@ -10,2 +10,3 @@
+ #include "config.h"
++#include <stdlib.h> /* atexit */
+ #ifdef LINUX_DRIVER
+@@ -135,3 +136,3 @@ static int get_keyb_map(void)
+
+- if (ioctl(tty_fd, KDGKBENT, (unsigned int) &keyb_ent))
++ if (ioctl(tty_fd, KDGKBENT, &keyb_ent))
+ return (0);
+@@ -144,3 +145,3 @@ static int get_keyb_map(void)
+
+- if (ioctl(tty_fd, KDGKBENT, (unsigned int) &keyb_ent))
++ if (ioctl(tty_fd, KDGKBENT, &keyb_ent))
+ return (0);
+@@ -200,3 +201,3 @@ static int rawmode_init(void)
+ if (!closed)
+- return;
++ return (1);
+ mypid = getpid();
+diff --git a/src/aamoureg.c b/src/aamoureg.c
+index bb55fe3..4a533b6 100644
+--- a/src/aamoureg.c
++++ b/src/aamoureg.c
+@@ -1,2 +1,3 @@
+ #include <stdlib.h>
++#include <string.h> /* strcmp */
+ #include "config.h"
+diff --git a/src/aaregist.c b/src/aaregist.c
+index 765155e..f9190ab 100644
+--- a/src/aaregist.c
++++ b/src/aaregist.c
+@@ -1,2 +1,3 @@
+ #include <stdlib.h>
++#include <string.h> /* strcmp */
+ #include "config.h"
+diff --git a/src/aaxkbd.c b/src/aaxkbd.c
+index dacc80f..c252cd9 100644
+--- a/src/aaxkbd.c
++++ b/src/aaxkbd.c
+@@ -7,2 +7,3 @@
+ #include <X11/Xlib.h>
++#include <X11/Xutil.h>
+ #include <X11/keysymdef.h>