summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@gentoo.org>2024-01-05 21:55:15 +0100
committerPetr Vaněk <arkamar@gentoo.org>2024-01-05 22:22:28 +0100
commite7be6699e01fd56063ef487feae7001687199863 (patch)
tree432d0f904bcfae8d9f43990bd136513ea6261cfa
parentdev-libs/libuninum: fix incompatible pointer type (diff)
downloadgentoo-e7be6699.tar.gz
gentoo-e7be6699.tar.bz2
gentoo-e7be6699.zip
app-doc/zsh-lovers: add 0.10.1
Signed-off-by: Petr Vaněk <arkamar@gentoo.org>
-rw-r--r--app-doc/zsh-lovers/Manifest1
-rw-r--r--app-doc/zsh-lovers/zsh-lovers-0.10.1.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/app-doc/zsh-lovers/Manifest b/app-doc/zsh-lovers/Manifest
index aa3df002141d..b9ee14aa7a92 100644
--- a/app-doc/zsh-lovers/Manifest
+++ b/app-doc/zsh-lovers/Manifest
@@ -1 +1,2 @@
+DIST zsh-lovers_0.10.1.tar.xz 26796 BLAKE2B 6ccaf0dda0c7b05131fa1e8f5ccfe29a6e86a503b2b934af704f2d1d15d4826a88b33373b4d83be92cb89c4f52a7665e754982c27bcdb9c582483e8a3d224253 SHA512 b07da3c65a01d3711900ed50b2d0c158be678d5168a0f864c77be52b77e595320e0380173e5b454bdc8b63d28fc437203e6deccdebdfc36b40a0adf2b1a39735
DIST zsh-lovers_0.9.1.tar.xz 26632 BLAKE2B b5c5015e7e61c21452b688aa46529dd468beac5a034b844185e1a497778a1c83b9d8124551a7b0dfd0d441394b0bf71fe64f4af5af7add3956c0a2a2f79f01ca SHA512 16493f2ec095fbdb992188a732ca4205880fa10fc1f1ab6cde8cbd2a0977d95bb06e46d1635c0c9910c249bec024f3cd13a1f8c6597e5201ef8a26b80fac9c2f
diff --git a/app-doc/zsh-lovers/zsh-lovers-0.10.1.ebuild b/app-doc/zsh-lovers/zsh-lovers-0.10.1.ebuild
new file mode 100644
index 000000000000..cb53a59881a4
--- /dev/null
+++ b/app-doc/zsh-lovers/zsh-lovers-0.10.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Tips, tricks and examples for the Z shell"
+HOMEPAGE="
+ https://grml.org/zsh/zsh-lovers.html
+ https://github.com/grml/zsh-lovers
+"
+SRC_URI="https://deb.grml.org/pool/main/z/${PN}/${PN}_${PV}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+DEPEND="app-text/asciidoc"
+
+src_compile() {
+ asciidoc ${PN}.1.txt || die
+ mv ${PN}.1.html ${PN}.html || die
+ a2x -f manpage ${PN}.1.txt || die
+}
+
+src_install() {
+ doman ${PN}.1
+ dodoc ${PN}.html
+}