summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2021-05-25 11:40:51 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2021-05-25 11:41:03 -0700
commite7c6961ffbbf0d8b82a9a509b6bf21cd4fdcb0df (patch)
tree6339b5c2de5901452f1162a7fe80778efd5d0df8
parentx11-misc/xwallpaper: add whitespace (diff)
downloadgentoo-e7c6961ffbbf0d8b82a9a509b6bf21cd4fdcb0df.tar.gz
gentoo-e7c6961ffbbf0d8b82a9a509b6bf21cd4fdcb0df.tar.bz2
gentoo-e7c6961ffbbf0d8b82a9a509b6bf21cd4fdcb0df.zip
x11-misc/xwallpaper: add 0.7.0
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
-rw-r--r--x11-misc/xwallpaper/Manifest1
-rw-r--r--x11-misc/xwallpaper/xwallpaper-0.7.0.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/x11-misc/xwallpaper/Manifest b/x11-misc/xwallpaper/Manifest
index 175b7d7bc35d..541e075415ee 100644
--- a/x11-misc/xwallpaper/Manifest
+++ b/x11-misc/xwallpaper/Manifest
@@ -2,3 +2,4 @@ DIST xwallpaper-0.6.2.tar.xz 82600 BLAKE2B 2e2b1121fcc2481c4a1e3c78e357534b9609b
DIST xwallpaper-0.6.4.tar.xz 82752 BLAKE2B e81a1a9ec56ffe0a1953f1186c945c9ebb143ff683b8c0c01b819506b79520738935d04725420a24b38119221cbb71d9a5562bffd03e03736c65ba7e3c6a1713 SHA512 531910957c44f7e5ce7357fa46737967f673aeca53868012211eb91507f78bd028f8d84fcbee6e1237107816a09f8247cd0445c0907b60792ff5d07416630d56
DIST xwallpaper-0.6.5.tar.xz 82696 BLAKE2B 8c12bcce2a2eeb9580038b172b51284cc9fa851f01bef34e7cfeb13ccc05879f5443ef0b7fd39a4f0d5abcc399ec614db28f6f6db6847505855128348fd22d4b SHA512 99c911c6a4f7501101d85532cfb9956fa4affb57f7836e9216e5e0d873ed34c9e7d0a9983def442a4728a682a3351268905e22174dc9a14d003dc36c42ed9615
DIST xwallpaper-0.6.6.tar.xz 85368 BLAKE2B fcb0861d4cecbafc980208b3d2a174b9931a93cd8110b6f2c38eddae19e890295ce5d6d75dc4f09924279a2b0463234f4efdb4dda758ed14ed728abfec6b9bf3 SHA512 e37055b9adfa6950fb423228ff880afaa03dbdf2a7ced6ab1e110dbf4813f68aae3c9147668ebd20665b582bea195470c39b6948cd36879afe54d61c90b6f8d9
+DIST xwallpaper-0.7.0.tar.xz 86224 BLAKE2B bc201d2136b8c0f04e54a83b624d4cdd45409cdc451f2103a826e261fe7fbee2dd450297f67a9f9411b8723c82bc8032c2177ab318eaa95dbcad1007c47c982c SHA512 b8b01a1c0d5768beba9e57c376b89f5d777360ba27edd20d0fab0bb018f25a11cb3bcd1aa36099dd1bd43f689d470aa07c0c0a52ab782ea0cf12ba13ba4cc818
diff --git a/x11-misc/xwallpaper/xwallpaper-0.7.0.ebuild b/x11-misc/xwallpaper/xwallpaper-0.7.0.ebuild
new file mode 100644
index 000000000000..4b3d25796853
--- /dev/null
+++ b/x11-misc/xwallpaper/xwallpaper-0.7.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Wallpaper setting utility for X"
+HOMEPAGE="https://github.com/stoeckmann/xwallpaper"
+
+if [ ${PV} == "9999" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/stoeckmann/${PN}.git"
+else
+ SRC_URI="https://github.com/stoeckmann/${PN}/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~ppc64 ~x86"
+fi
+
+LICENSE="ISC"
+SLOT="0"
+IUSE="jpeg png seccomp xpm"
+
+RDEPEND="
+ x11-libs/pixman
+ x11-libs/xcb-util
+ x11-libs/xcb-util-image
+ jpeg? ( media-libs/libjpeg-turbo:= )
+ png? ( media-libs/libpng:0= )
+ seccomp? ( >=sys-libs/libseccomp-2.3.1:0= )
+ xpm? ( x11-libs/libXpm )
+"
+
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=(
+ $(use_with jpeg)
+ $(use_with png)
+ $(use_with seccomp)
+ $(use_with xpm)
+ --with-randr
+ )
+ econf "${myconf[@]}"
+}