summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-02 15:51:55 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-02 15:53:46 +0200
commite7c8021b3f55bf99c4d06ec2a5fb1776e40aecdc (patch)
treeaa8ed3a370948068394a6e80921e566920ae1482
parentdev-python/nbformat: Fix hardcoded version number (diff)
downloadgentoo-e7c8021b3f55bf99c4d06ec2a5fb1776e40aecdc.tar.gz
gentoo-e7c8021b3f55bf99c4d06ec2a5fb1776e40aecdc.tar.bz2
gentoo-e7c8021b3f55bf99c4d06ec2a5fb1776e40aecdc.zip
dev-python/nbformat: Use hatch-nodejs-version
Bug: https://bugs.gentoo.org/928427 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/nbformat/nbformat-5.10.3-r2.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/nbformat/nbformat-5.10.3-r2.ebuild b/dev-python/nbformat/nbformat-5.10.3-r2.ebuild
new file mode 100644
index 000000000000..8ab93baa2ee3
--- /dev/null
+++ b/dev-python/nbformat/nbformat-5.10.3-r2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+PYTHON_REQ_USE='sqlite'
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Reference implementation of the Jupyter Notebook format"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter/nbformat/
+ https://pypi.org/project/nbformat/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/fastjsonschema[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-2.6[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-5.1[${PYTHON_USEDEP}]
+ dev-python/jupyter-core[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-nodejs-version[${PYTHON_USEDEP}]
+ test? (
+ dev-python/testpath[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs \
+ dev-python/myst-parser \
+ dev-python/pydata-sphinx-theme \
+ dev-python/sphinxcontrib-github-alt \
+ dev-python/sphinxcontrib-spelling
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # requires pep440 package, which is not really relevant for us
+ tests/test_api.py
+)