summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRahil Bhimjiani <me@rahil.rocks>2024-02-03 14:44:54 +0530
committerSam James <sam@gentoo.org>2024-02-03 10:52:20 +0000
commite7fd3a2d1198dd0b9e1a0d42f05f6e01f27da0ff (patch)
treecafa07b402558dad2d35d427537d5558a8b6df7f
parentdev-python/xarray: Stabilize 2024.1.0 arm, #923687 (diff)
downloadgentoo-e7fd3a2d1198dd0b9e1a0d42f05f6e01f27da0ff.tar.gz
gentoo-e7fd3a2d1198dd0b9e1a0d42f05f6e01f27da0ff.tar.bz2
gentoo-e7fd3a2d1198dd0b9e1a0d42f05f6e01f27da0ff.zip
app-containers/containers-image: bump to 5.29.2-r1
Apologies from my side, I let the bug slip in Closes: https://bugs.gentoo.org/show_bug.cgi?id=923700 Signed-off-by: Rahil Bhimjiani <me@rahil.rocks> Closes: https://github.com/gentoo/gentoo/pull/35166 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-containers/containers-image/containers-image-5.29.2-r1.ebuild (renamed from app-containers/containers-image/containers-image-5.29.2.ebuild)1
-rw-r--r--app-containers/containers-image/containers-image-9999.ebuild3
-rw-r--r--app-containers/containers-image/files/prevent-downloading-mods-5.29.2.patch10
3 files changed, 14 insertions, 0 deletions
diff --git a/app-containers/containers-image/containers-image-5.29.2.ebuild b/app-containers/containers-image/containers-image-5.29.2-r1.ebuild
index 0a3bb536ab4f..ddd9efcc26d5 100644
--- a/app-containers/containers-image/containers-image-5.29.2.ebuild
+++ b/app-containers/containers-image/containers-image-5.29.2-r1.ebuild
@@ -23,6 +23,7 @@ RESTRICT='test'
BDEPEND=">=dev-go/go-md2man-2.0.3"
PATCHES=(
"${FILESDIR}"/moving-policy-json-default-yaml.patch
+ "${FILESDIR}"/prevent-downloading-mods-5.29.2.patch
)
src_compile() {
diff --git a/app-containers/containers-image/containers-image-9999.ebuild b/app-containers/containers-image/containers-image-9999.ebuild
index 4fb96c1222c3..2df39141c68d 100644
--- a/app-containers/containers-image/containers-image-9999.ebuild
+++ b/app-containers/containers-image/containers-image-9999.ebuild
@@ -21,6 +21,9 @@ SLOT="0"
# https://github.com/gentoo/gentoo/pull/35012#discussion_r1473740969
RESTRICT='test'
BDEPEND=">=dev-go/go-md2man-2.0.3"
+PATCHES=(
+ "${FILESDIR}"/prevent-downloading-mods-5.29.2.patch
+)
src_compile() {
emake docs
diff --git a/app-containers/containers-image/files/prevent-downloading-mods-5.29.2.patch b/app-containers/containers-image/files/prevent-downloading-mods-5.29.2.patch
new file mode 100644
index 000000000000..8d70156bfb6f
--- /dev/null
+++ b/app-containers/containers-image/files/prevent-downloading-mods-5.29.2.patch
@@ -0,0 +1,10 @@
+--- a/Makefile
++++ b/Makefile
+@@ -15,7 +15,6 @@
+ BUILDTAGS = btrfs_noversion libdm_no_deferred_remove
+ BUILDFLAGS := -tags "$(BUILDTAGS)"
+
+-PACKAGES := $(shell GO111MODULE=on go list $(BUILDFLAGS) ./...)
+ SOURCE_DIRS = $(shell echo $(PACKAGES) | awk 'BEGIN{FS="/"; RS=" "}{print $$4}' | uniq)
+
+ PREFIX ?= ${DESTDIR}/usr