summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-05-06 09:11:51 -0700
committerMatt Turner <mattst88@gentoo.org>2022-05-06 09:12:15 -0700
commite800503c726624a14b4ec7563bd6cc1eb0c95f98 (patch)
tree35b4f987008f763fdda09561c63174e5d0fd95f2
parentnet-proxy/haproxy: Bump (diff)
downloadgentoo-e800503c.tar.gz
gentoo-e800503c.tar.bz2
gentoo-e800503c.zip
dev-util/nemiver: Remove
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--dev-util/nemiver/Manifest1
-rw-r--r--dev-util/nemiver/files/nemiver-0.9.6-bool-build.patch36
-rw-r--r--dev-util/nemiver/files/nemiver-0.9.6-fix-build.patch39
-rw-r--r--dev-util/nemiver/files/nemiver-0.9.6-gcc6-throw-in-dtors.patch73
-rw-r--r--dev-util/nemiver/metadata.xml15
-rw-r--r--dev-util/nemiver/nemiver-0.9.6.ebuild60
-rw-r--r--profiles/package.mask5
7 files changed, 0 insertions, 229 deletions
diff --git a/dev-util/nemiver/Manifest b/dev-util/nemiver/Manifest
deleted file mode 100644
index f326e4753075..000000000000
--- a/dev-util/nemiver/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST nemiver-0.9.6.tar.xz 1427660 BLAKE2B c7b9aeb7914498af540f664f435cb2e9c07f8b2845f8bc6f5bdc3ee2b2173346d964d44ce4a588665180670cca61581397f33bfc5ac8dd2b3501e8d951d8dec5 SHA512 6fd941975af6e9ba98d7100daf8205f8b61f75ccde4aaf30145a4e2beafe1b96b14ab70d22db7c258aabc7c1a71d4787aa121bc4e943b3fc310e00c13feb4f21
diff --git a/dev-util/nemiver/files/nemiver-0.9.6-bool-build.patch b/dev-util/nemiver/files/nemiver-0.9.6-bool-build.patch
deleted file mode 100644
index dac65a8a4cc0..000000000000
--- a/dev-util/nemiver/files/nemiver-0.9.6-bool-build.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-From 262cf9657f9c2727a816972b348692adcc666008 Mon Sep 17 00:00:00 2001
-From: Marcin Kolny <marcin.kolny@gmail.com>
-Date: Fri, 1 Jul 2016 19:45:05 +0200
-Subject: Use RefPtr::bool() operator in the conditions
-
-Since bool() operator in RefPtr class is explicit,
-comparision with integer doesn't compile.
----
- src/persp/dbgperspective/nmv-dbg-perspective.cc | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/src/persp/dbgperspective/nmv-dbg-perspective.cc b/src/persp/dbgperspective/nmv-dbg-perspective.cc
-index be652db..ac207e4 100644
---- a/src/persp/dbgperspective/nmv-dbg-perspective.cc
-+++ b/src/persp/dbgperspective/nmv-dbg-perspective.cc
-@@ -5672,7 +5672,7 @@ DBGPerspective::switch_to_asm (const common::DisassembleInfo &a_info,
- a_source_editor->clear_decorations ();
-
- Glib::RefPtr<Gsv::Buffer> asm_buf;
-- if ((asm_buf = a_source_editor->get_assembly_source_buffer ()) == 0) {
-+ if (!(asm_buf = a_source_editor->get_assembly_source_buffer ())) {
- SourceEditor::setup_buffer_mime_and_lang (asm_buf, "text/x-asm");
- a_source_editor->register_assembly_source_buffer (asm_buf);
- asm_buf = a_source_editor->get_assembly_source_buffer ();
-@@ -5720,7 +5720,7 @@ DBGPerspective::switch_to_source_code ()
-
- Glib::RefPtr<Gsv::Buffer> source_buf;
- UString source_path;
-- if ((source_buf = source_editor->get_non_assembly_source_buffer ()) == 0) {
-+ if (!(source_buf = source_editor->get_non_assembly_source_buffer ())) {
- // Woops!
- // We don't have any source code buffer. Let's try hard to get
- // the source code corresponding to the current frame. For that,
---
-cgit v0.12
-
diff --git a/dev-util/nemiver/files/nemiver-0.9.6-fix-build.patch b/dev-util/nemiver/files/nemiver-0.9.6-fix-build.patch
deleted file mode 100644
index 59a893ad003a..000000000000
--- a/dev-util/nemiver/files/nemiver-0.9.6-fix-build.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-From e0e42221ceb77d88be64fac1c09792dc5c9e2f43 Mon Sep 17 00:00:00 2001
-From: Ben Iofel <iofelben@gmail.com>
-Date: Thu, 17 Mar 2016 18:28:02 -0400
-Subject: Fix compiliation warnings & errors
-
----
- src/dbgengine/nmv-dbg-common.h | 2 +-
- src/dbgengine/nmv-i-var-list-walker.h | 2 +-
- 2 files changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/src/dbgengine/nmv-dbg-common.h b/src/dbgengine/nmv-dbg-common.h
-index ad3cc00..0edac7c 100644
---- a/src/dbgengine/nmv-dbg-common.h
-+++ b/src/dbgengine/nmv-dbg-common.h
-@@ -171,7 +171,7 @@ public:
-
- bool has_slot () const
- {
-- return m_slot;
-+ return static_cast<bool> (m_slot);
- }
-
- template<class T>
-diff --git a/src/dbgengine/nmv-i-var-list-walker.h b/src/dbgengine/nmv-i-var-list-walker.h
-index b719c0d..f2f3229 100644
---- a/src/dbgengine/nmv-i-var-list-walker.h
-+++ b/src/dbgengine/nmv-i-var-list-walker.h
-@@ -22,7 +22,7 @@
- *
- *See COPYRIGHT file copyright information.
- */
--#ifndef __NMV_VAR_LIST_WALKER_H__
-+#ifndef __NMV_I_VAR_LIST_WALKER_H__
- #define __NMV_I_VAR_LIST_WALKER_H__
-
- #include "nmv-i-var-walker.h"
---
-cgit v0.12
-
diff --git a/dev-util/nemiver/files/nemiver-0.9.6-gcc6-throw-in-dtors.patch b/dev-util/nemiver/files/nemiver-0.9.6-gcc6-throw-in-dtors.patch
deleted file mode 100644
index 91d90961cb4a..000000000000
--- a/dev-util/nemiver/files/nemiver-0.9.6-gcc6-throw-in-dtors.patch
+++ /dev/null
@@ -1,73 +0,0 @@
-Bug: https://bugs.gentoo.org/602436
-Upstream PR: https://github.com/GNOME/nemiver/pull/3
-
---- a/src/common/nmv-api-macros.h
-+++ b/src/common/nmv-api-macros.h
-@@ -52,5 +52,12 @@
- # define NEMIVER_PURE_IFACE
- # define NEMIVER_API
- # endif //HAS_GCC_VISIBILITY_SUPPORT
-+
-+# if __cplusplus >= 201103L
-+# define DTOR_NOEXCEPT noexcept(false)
-+# else
-+# define DTOR_NOEXCEPT
-+# endif //__cplusplus >= 201103L
-+
- #endif
-
---- a/src/common/nmv-log-stream.cc
-+++ b/src/common/nmv-log-stream.cc
-@@ -393,7 +393,7 @@
- }
- }
-
--LogStream::~LogStream ()
-+LogStream::~LogStream () DTOR_NOEXCEPT
- {
- LOG_D ("delete", "destructor-domain");
- if (!m_priv) throw runtime_error ("double free in LogStrea::~LogStream");
---- a/src/common/nmv-log-stream.h
-+++ b/src/common/nmv-log-stream.h
-@@ -151,7 +151,7 @@
- const string &a_default_domain=NMV_GENERAL_DOMAIN);
-
- /// \brief destructor of the log stream class
-- virtual ~LogStream ();
-+ virtual ~LogStream () DTOR_NOEXCEPT;
-
- /// \brief enable or disable logging for a domain
- /// \param a_domain the domain to enable logging for
---- a/src/common/nmv-object.cc
-+++ b/src/common/nmv-object.cc
-@@ -68,7 +68,7 @@
- return *this;
- }
-
--Object::~Object ()
-+Object::~Object () DTOR_NOEXCEPT
- {
- }
-
---- a/src/common/nmv-object.h
-+++ b/src/common/nmv-object.h
-@@ -54,7 +54,7 @@
-
- Object& operator= (Object const&);
-
-- virtual ~Object ();
-+ virtual ~Object () DTOR_NOEXCEPT;
-
- void ref ();
-
---- a/src/common/nmv-transaction.h
-+++ b/src/common/nmv-transaction.h
-@@ -116,7 +116,7 @@
- return m_trans;
- }
-
-- ~TransactionAutoHelper ()
-+ ~TransactionAutoHelper () DTOR_NOEXCEPT
- {
- if (m_ignore) {
- return;
diff --git a/dev-util/nemiver/metadata.xml b/dev-util/nemiver/metadata.xml
deleted file mode 100644
index 332d50cbbaba..000000000000
--- a/dev-util/nemiver/metadata.xml
+++ /dev/null
@@ -1,15 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>gnome@gentoo.org</email>
- <name>Gentoo GNOME Desktop</name>
- </maintainer>
- <longdescription>
- Nemiver is an on going effort to write an easy to use standalone C/C++
- debugger that integrates well in the GNOME environment.
- </longdescription>
- <use>
- <flag name="memoryview">Enable the optional hexadecimal memory inspection with <pkg>app-editors/ghex</pkg></flag>
- </use>
-</pkgmetadata>
diff --git a/dev-util/nemiver/nemiver-0.9.6.ebuild b/dev-util/nemiver/nemiver-0.9.6.ebuild
deleted file mode 100644
index b5d54807fe31..000000000000
--- a/dev-util/nemiver/nemiver-0.9.6.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-GNOME2_LA_PUNT="yes"
-
-inherit eutils gnome2
-
-DESCRIPTION="A gtkmm front end to the GNU Debugger (gdb)"
-HOMEPAGE="https://wiki.gnome.org/Apps/Nemiver"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="debug memoryview"
-
-RDEPEND="
- >=dev-libs/glib-2.16:2[dbus]
- >=dev-cpp/glibmm-2.30:2
- >=dev-cpp/gtkmm-3:3.0
- >=dev-cpp/gtksourceviewmm-3:3.0
- >=gnome-base/gsettings-desktop-schemas-0.0.1
- >=gnome-base/libgtop-2.19
- x11-libs/vte:2.91
- >=dev-db/sqlite-3:3
- sys-devel/gdb
- dev-libs/boost
- memoryview? ( >=app-editors/ghex-2.90:2 )
-"
-# FIXME: dynamiclayout needs unreleased stable gdlmm:3
-# dynamiclayout? ( >=dev-cpp/gdlmm-3.0:3 )
-DEPEND="${RDEPEND}
- app-text/docbook-xml-dtd:4.1.2
- >=dev-util/intltool-0.40
- dev-util/itstool
- >=sys-devel/gettext-0.17
- virtual/pkgconfig
-"
-
-PATCHES=(
- # Use RefPtr::bool() operator in the conditions, fixed in next
- # version
- "${FILESDIR}/${P}-bool-build.patch"
-
- # Fix compiliation warnings & errors, fixed in next version
- "${FILESDIR}/${P}-fix-build.patch"
-
- # Fix building with GCC-6 and CXXFLAGS="-Werror=terminate"
- "${FILESDIR}/${P}-gcc6-throw-in-dtors.patch"
-)
-
-src_configure() {
- gnome2_src_configure \
- --disable-dynamiclayout \
- --disable-static \
- --disable-symsvis \
- --enable-gsettings \
- $(use_enable debug) \
- $(use_enable memoryview)
-}
diff --git a/profiles/package.mask b/profiles/package.mask
index bb14df058449..0aef7837d75c 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -387,11 +387,6 @@ dev-python/repoze-sphinx-autointerface
# Removal on 2022-05-09. Bug #837530.
dev-python/zope-testrunner
-# Matt Turner <mattst88@gentoo.org> (2022-04-06)
-# Dead package upstream. No reverse dependencies.
-# Removal on 2022-05-06
-dev-util/nemiver
-
# David Seifert <soap@gentoo.org> (2022-04-06)
# Unsupported branches, no consumers left, removal on 2023-01-01.
sys-devel/automake:1.13