summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2017-11-12 17:49:54 -0500
committerAnthony G. Basile <blueness@gentoo.org>2017-11-12 17:50:16 -0500
commite803961c8e6cf1e7fec1f1a9798970ffeba7d59f (patch)
tree497f21a728ecba5654c6e99da56b92f99617ca2d
parentwww-client/chromium: beta channel bump (63.0.3239.40) (diff)
downloadgentoo-e803961c.tar.gz
gentoo-e803961c.tar.bz2
gentoo-e803961c.zip
sys-fs/f2fs-tools: version bump 1.9.0, bug #637250
Package-Manager: Portage-2.3.8, Repoman-2.3.3
-rw-r--r--sys-fs/f2fs-tools/Manifest1
-rw-r--r--sys-fs/f2fs-tools/f2fs-tools-1.9.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/sys-fs/f2fs-tools/Manifest b/sys-fs/f2fs-tools/Manifest
index b7608b738b02..f36537830c53 100644
--- a/sys-fs/f2fs-tools/Manifest
+++ b/sys-fs/f2fs-tools/Manifest
@@ -1,2 +1,3 @@
DIST f2fs-tools-1.6.1.tar.xz 282152 SHA256 1c2f9ab663d26c939924ad6bbcfbacf676bec1f6dbae8f9ef5362ade4b03d885 SHA512 108327042079d9e864899a20f2dd94019be1b957fd7ffa295af097c5b93a5065ea9c36de9bae83f84a6412ac496340849fc44de041e24461a2919073eed15cf2 WHIRLPOOL b5659154da6e48138b4f49481a68b25c95ba2461971609b4cb0399d173a7c0e5b0203baccd8da2adc7a8c2d7b078620649aea9ee57739498452a8b946fb43836
DIST f2fs-tools-1.8.0.tar.xz 301108 SHA256 0d9b00d9e873da4508bb297c7a5ef46050af350deb21b32898c16ed5164bb6a4 SHA512 aff27e1113cc3034194e496883570143bd6a3cc7cc077e868255052298a401cc36c423579b4e695fe3e480d770ae05f9d14d9bb4bbc0311bdd5e23e37950a27f WHIRLPOOL 4a7ae8533e4a02bd9d1ee09461c7bd30e8ef8d47bcc4e7adfe631eb14c2231fb0db9a253eeca7d0437296ad65abd446ab2249bc48ccc07b89f923d078d17e4dc
+DIST f2fs-tools-1.9.0.tar.xz 337676 SHA256 04a655ce471f3ee1f62a72e4d9213f563b2ab0c60e7469765be5b9a965c6950a SHA512 aa76d4bf595b3d17607846f2531327f2c26c8724b4fdb2572074e028965c2300fcd880d57246f5c15d8dd4b9ae62fc93552edecdd504d7313fca5839590f16e5 WHIRLPOOL 8568fc6790ea6e4cf5e83ab13093c995de29408501a8ceb035408c51c6693a9d300082e413d63536120a760120ec03d352eb90e8bb6b44077af2fa6e7e31d86d
diff --git a/sys-fs/f2fs-tools/f2fs-tools-1.9.0.ebuild b/sys-fs/f2fs-tools/f2fs-tools-1.9.0.ebuild
new file mode 100644
index 000000000000..ed0af30bce68
--- /dev/null
+++ b/sys-fs/f2fs-tools/f2fs-tools-1.9.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Tools for Flash-Friendly File System (F2FS)"
+HOMEPAGE="https://git.kernel.org/cgit/linux/kernel/git/jaegeuk/f2fs-tools.git/about/"
+SRC_URI="https://dev.gentoo.org/~blueness/f2fs-tools/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0/3"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86"
+IUSE="selinux"
+
+RDEPEND="
+ sys-apps/util-linux
+ selinux? ( sys-libs/libselinux )"
+DEPEND="$RDEPEND"
+
+src_configure() {
+ #This is required to install to /sbin, bug #481110
+ econf \
+ --bindir="${EPREFIX}"/sbin \
+ --disable-static \
+ $(use_with selinux)
+}
+
+src_install() {
+ default
+ find "${D}" -name "*.la" -delete || die
+}