summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-14 10:20:24 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-14 10:20:24 +0200
commite80623f96bd8b55b0a4badb9b429b9f25ac39dd0 (patch)
tree842847c08545bdf93ae732bc8c9276721d6624fd
parentnet-print/hplip: add 3.23.8 (diff)
downloadgentoo-e80623f96bd8b55b0a4badb9b429b9f25ac39dd0.tar.gz
gentoo-e80623f96bd8b55b0a4badb9b429b9f25ac39dd0.tar.bz2
gentoo-e80623f96bd8b55b0a4badb9b429b9f25ac39dd0.zip
xfce-base/libxfce4ui: Bump to 4.19.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--xfce-base/libxfce4ui/Manifest1
-rw-r--r--xfce-base/libxfce4ui/libxfce4ui-4.19.3.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/xfce-base/libxfce4ui/Manifest b/xfce-base/libxfce4ui/Manifest
index 8de60f59f2b7..86a7c2e1dc64 100644
--- a/xfce-base/libxfce4ui/Manifest
+++ b/xfce-base/libxfce4ui/Manifest
@@ -1,2 +1,3 @@
DIST libxfce4ui-4.18.4.tar.bz2 907248 BLAKE2B 785ec91bcb2995d289423ac666832b642e1cd1c2685e9bb5b6781ca6c7272d7e85e163a55b137602401ed9a18f1b8e29492e3b7bd1d74951544e71a4338860ae SHA512 e931d38319bcc0dcfa854642f604fcd782ffb27a160ae7e2625d7a276625635131b0451c12ccd502b68366283c503ad21536389e70da6912e46eb16b97f28642
DIST libxfce4ui-4.19.2.tar.bz2 1168536 BLAKE2B 13bfd0b732358cd704d3c557aeda190594b13aadb5536fb6869af68f01ec918c5131e1c3b1f519a0331695a1a548c006c307ae4f66deaa3984f825824e186afe SHA512 b43b45c271b79b0a23c11184828f8438c3920525f2839bb5da194070cc8fecdd85933f4ff8e302508f2e9106b92cd10da15a25c9297780cd15a17feb31f036ea
+DIST libxfce4ui-4.19.3.tar.bz2 1169903 BLAKE2B 175e88fa58712933c681a8851c787d7322d806005cd450e3db3d3a7744ea08a599ddba071944c031e047365c4fec70b0144f84a3ed491b9bd5efb7a359233303 SHA512 3361de52cd48318cdd5a61d26a741336f4168fa98a284faee5ac53460dc875625df73084aec65e8203cea7438f9b8bd64cfd456ab9803c330a554aa6f444529a
diff --git a/xfce-base/libxfce4ui/libxfce4ui-4.19.3.ebuild b/xfce-base/libxfce4ui/libxfce4ui-4.19.3.ebuild
new file mode 100644
index 000000000000..059b5c4f7a2c
--- /dev/null
+++ b/xfce-base/libxfce4ui/libxfce4ui-4.19.3.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils vala
+
+DESCRIPTION="Unified widget and session management libs for Xfce"
+HOMEPAGE="
+ https://docs.xfce.org/xfce/libxfce4ui/start
+ https://gitlab.xfce.org/xfce/libxfce4ui/
+"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2+ GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="glade +introspection startup-notification system-info vala"
+REQUIRED_USE="vala? ( introspection )"
+
+DEPEND="
+ >=dev-libs/glib-2.66.0
+ >=x11-libs/gtk+-3.24.0:3[introspection?,X]
+ x11-libs/libX11
+ x11-libs/libICE
+ x11-libs/libSM
+ >=xfce-base/libxfce4util-4.17.2:=[introspection?,vala?]
+ >=xfce-base/xfconf-4.12:=
+ glade? ( dev-util/glade:3.10 )
+ introspection? ( >=dev-libs/gobject-introspection-1.66:= )
+ startup-notification? ( x11-libs/startup-notification )
+ system-info? (
+ dev-libs/libgudev
+ gnome-base/libgtop
+ >=media-libs/libepoxy-1.2
+ )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-lang/perl
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable introspection)
+ $(use_enable system-info glibtop)
+ $(use_enable system-info epoxy)
+ $(use_enable system-info gudev)
+ $(use_enable startup-notification)
+ $(use_enable vala)
+ $(use_enable glade gladeui2)
+ --with-vendor-info=Gentoo
+ )
+
+ use vala && vala_setup
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}