summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-17 07:28:30 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-17 08:25:39 +0200
commite817321d83123513e157f266255a08779d6e27f4 (patch)
tree9e27a76ac2e9a15b36d2b9a2fe8b5bcdd4a1c649
parentdev-python/aws-sam-translator: Bump to 1.89.0 (diff)
downloadgentoo-e817321d83123513e157f266255a08779d6e27f4.tar.gz
gentoo-e817321d83123513e157f266255a08779d6e27f4.tar.bz2
gentoo-e817321d83123513e157f266255a08779d6e27f4.zip
dev-util/stripe-mock: Bump to 0.186.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-util/stripe-mock/Manifest1
-rw-r--r--dev-util/stripe-mock/stripe-mock-0.186.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-util/stripe-mock/Manifest b/dev-util/stripe-mock/Manifest
index 7a8caef432d2..2419bf5716d8 100644
--- a/dev-util/stripe-mock/Manifest
+++ b/dev-util/stripe-mock/Manifest
@@ -1 +1,2 @@
DIST stripe-mock-0.185.0.tar.gz 1605001 BLAKE2B 4e44e6d3bb58ea650583317a07e085ba919c8fc183456ebc0a6821420eccc968642411e7e6589e3808bb07512ffab6b8078ffc3400b565f4c4977e68f9a4c306 SHA512 9ef5fce0c393ce7131dfc24587e19f6b3bc456b0b4650be8d70eac05cbcf37a6024f2deca1f763168609ee903b9d4045f0c36ee56c7b140410e34d7c393ea2dc
+DIST stripe-mock-0.186.0.tar.gz 1617203 BLAKE2B a98ac19f23e9e15514c221df3e857a14bffc261e3e5d93cd8db1f821fdb37a97b49d74b9cadbcf752412b19a9757eed7c1d0e072b33eff83d40cce5d81f303be SHA512 7003eded0bc88442b3b8d66f6f943a2b438da783f1f3c8bccb1dc3c760f090e64faea08efd5ba544be7dc516657616f50040300c78f7ce10f2095d1e36576cc0
diff --git a/dev-util/stripe-mock/stripe-mock-0.186.0.ebuild b/dev-util/stripe-mock/stripe-mock-0.186.0.ebuild
new file mode 100644
index 000000000000..352d14e2ce00
--- /dev/null
+++ b/dev-util/stripe-mock/stripe-mock-0.186.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="Mock HTTP server that responds like the real Stripe API"
+HOMEPAGE="https://github.com/stripe/stripe-mock/"
+SRC_URI="https://github.com/stripe/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT ISC BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+src_compile() {
+ emake build
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ dobin stripe-mock
+ einstalldocs
+}