summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Tsoy <alexander@tsoy.me>2020-01-29 14:57:34 +0300
committerJoonas Niilola <juippis@gentoo.org>2020-01-30 08:33:07 +0200
commite82d0a5251dd59099ed8f07308d2b87374ac2afc (patch)
treee690ab3790a5eb1670c9f824832c4b151d1474e7
parentdev-python/xapp: use DISTUTILS_USE_SETUPTOOLS (diff)
downloadgentoo-e82d0a52.tar.gz
gentoo-e82d0a52.tar.bz2
gentoo-e82d0a52.zip
x11-misc/x11vnc: fix build with -fno-common
Closes: https://bugs.gentoo.org/706840 Signed-off-by: Alexander Tsoy <alexander@tsoy.me> Closes: https://github.com/gentoo/gentoo/pull/14495 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--x11-misc/x11vnc/files/x11vnc-0.9.16-fno-common.patch45
-rw-r--r--x11-misc/x11vnc/x11vnc-0.9.16-r3.ebuild3
2 files changed, 47 insertions, 1 deletions
diff --git a/x11-misc/x11vnc/files/x11vnc-0.9.16-fno-common.patch b/x11-misc/x11vnc/files/x11vnc-0.9.16-fno-common.patch
new file mode 100644
index 000000000000..504159efe92f
--- /dev/null
+++ b/x11-misc/x11vnc/files/x11vnc-0.9.16-fno-common.patch
@@ -0,0 +1,45 @@
+From a48b0b1cd887d7f3ae67f525d7d334bd2feffe60 Mon Sep 17 00:00:00 2001
+From: Alexander Tsoy <alexander@tsoy.me>
+Date: Tue, 28 Jan 2020 22:21:01 +0300
+Subject: [PATCH] Fix build with -fno-common
+
+GCC 10 defaults to -fno-common
+---
+ src/util.c | 3 +++
+ src/util.h | 6 +++---
+ 2 files changed, 6 insertions(+), 3 deletions(-)
+
+diff --git a/src/util.c b/src/util.c
+index a82a1a4..6a52ebf 100644
+--- a/src/util.c
++++ b/src/util.c
+@@ -47,6 +47,9 @@ int hxl = 0;
+ #ifdef LIBVNCSERVER_HAVE_LIBPTHREAD
+ MUTEX(x11Mutex);
+ MUTEX(scrollMutex);
++MUTEX(clientMutex);
++MUTEX(inputMutex);
++MUTEX(pointerMutex);
+ #endif
+
+ int nfix(int i, int n);
+diff --git a/src/util.h b/src/util.h
+index 35c1afd..99b5dd1 100644
+--- a/src/util.h
++++ b/src/util.h
+@@ -102,9 +102,9 @@ extern struct timeval _mysleep;
+ #ifdef LIBVNCSERVER_HAVE_LIBPTHREAD
+ extern MUTEX(x11Mutex);
+ extern MUTEX(scrollMutex);
+-MUTEX(clientMutex);
+-MUTEX(inputMutex);
+-MUTEX(pointerMutex);
++extern MUTEX(clientMutex);
++extern MUTEX(inputMutex);
++extern MUTEX(pointerMutex);
+ #endif
+
+ #define X_INIT INIT_MUTEX(x11Mutex)
+--
+2.24.1
+
diff --git a/x11-misc/x11vnc/x11vnc-0.9.16-r3.ebuild b/x11-misc/x11vnc/x11vnc-0.9.16-r3.ebuild
index bc16d70cde2d..f01cd79f6bad 100644
--- a/x11-misc/x11vnc/x11vnc-0.9.16-r3.ebuild
+++ b/x11-misc/x11vnc/x11vnc-0.9.16-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -44,6 +44,7 @@ PATCHES=(
"${FILESDIR}"/${P}-crypto.patch # https://github.com/LibVNC/x11vnc/issues/86
"${FILESDIR}"/${P}-anonymous-ssl.patch # https://github.com/LibVNC/x11vnc/pull/85
"${FILESDIR}"/${P}-libressl.patch
+ "${FILESDIR}"/${P}-fno-common.patch
)
src_prepare() {