summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-27 08:55:24 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-27 10:29:08 +0200
commite837a6b29f9b1ba1dc026b6e6979a745de253808 (patch)
treeff3cb92c295c8b85959cb4a5a8575888c33667a2
parentdev-python/boto3: Bump to 1.19.4 (diff)
downloadgentoo-e837a6b29f9b1ba1dc026b6e6979a745de253808.tar.gz
gentoo-e837a6b29f9b1ba1dc026b6e6979a745de253808.tar.bz2
gentoo-e837a6b29f9b1ba1dc026b6e6979a745de253808.zip
app-admin/awscli: Bump to 1.21.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.21.4.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index cf64ae43ed16..186c359b2d1b 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -9,3 +9,4 @@ DIST awscli-1.21.0.tar.gz 2092490 BLAKE2B 98684a1ba8f3efead1e4df7c266ae4b9dcabed
DIST awscli-1.21.1.tar.gz 2092333 BLAKE2B c222760f8491426cc141a67bbbb6a5c31691a3918e1e3b35256588666a796fd00990b2cdfdfdabee5eb64610c910e89cb55c972d7792f75c42489f58163b94b4 SHA512 daf130f6a24ed850e4e13851c8a1de5a139fb6b65f03b9471db33b1fe087e5fd2f087e7bc0c705204c0d62682a21142b708f0acc0e1ca3133173fbdf6a94f05e
DIST awscli-1.21.2.tar.gz 2093332 BLAKE2B 65115d78b004f08f422fe62f851eaccd479e32b75fda821281a320102891f4b3741a69ca387a5d9817c873533d6dc47ff7b394dbee8a2bfb1ed963a042542c61 SHA512 874a4bf3a0adcbea928c9a0f0c978e375a95350631aeec15f1115aca2f1bfc91b5f918c4414860bb9685d090dc5a947959dde648f66147941cab1587a18d1e0d
DIST awscli-1.21.3.tar.gz 2093712 BLAKE2B 5b3564f6109fb4b61af0d57445b6fceb2526e9052fec6ee33649b81da15617a09fb99176ed8735edb441a9cd5420b44b0afd044a8ad54c4941f40cafc78cdbf9 SHA512 98c923d5fdd15fe21601d4738abb1dde11bbde7397ecd14a3230ad1e2aa4bd7b72094e9d1f5ce8a0030f25fe189868b39bb54dca9fe959133715e5fed7de4a3d
+DIST awscli-1.21.4.tar.gz 2094591 BLAKE2B 5fe04384e33db4d047ffc8a1d19ec73faa4749ce1e5d0fbeba5a98e52123a47c6a648f6618bbf7a713f168f4a11c0d735a079186278cf2e8bb2e068f98e7db50 SHA512 2c2fba0753687d95a0b2c66f3b74ec5dae3ef4711e1f19f30e36020e1f5a4a71a3f10c5c579f401dd4853a9f8df9bd646b7e68f252544f1d9d9d5c92699abd1d
diff --git a/app-admin/awscli/awscli-1.21.4.ebuild b/app-admin/awscli/awscli-1.21.4.ebuild
new file mode 100644
index 000000000000..81d5997098c2
--- /dev/null
+++ b/app-admin/awscli/awscli-1.21.4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="https://pypi.org/project/awscli/"
+#SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/aws/aws-cli/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/aws-cli-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+# botocore is x.(y+1).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 1)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.4.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests --install pytest
+
+python_test() {
+ distutils_install_for_testing
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit}
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}