summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-04-21 22:33:31 +1200
committerKent Fredric <kentnl@gentoo.org>2017-04-21 22:33:31 +1200
commite84f62972cbd20ed83db1726eca62ca304a67ed8 (patch)
tree4cb4fad4f512636deeb3290a1f7da4508c8ecdd7
parentdev-libs/check: Fix missing dep on texinfo re bug #613852 (diff)
downloadgentoo-e84f6297.tar.gz
gentoo-e84f6297.tar.bz2
gentoo-e84f6297.zip
dev-lang/perl: Stop treating minor devrels as ABI compatible
Development releases of Perl are not ABI-intercompatible with each other, regardless of *actual* ABI compat, as Perl itself enforces minor-version breaks in XS code. Hence, this commit: 1. Ensures that development releases use the full 5.xx.yyy for the subslot 2. Ensures the arch-abi-path from older 5.ODD series is not shared with newer 5.ODD Package-Manager: Portage-2.3.4, Repoman-2.3.2
-rw-r--r--dev-lang/perl/perl-5.26.9999.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/dev-lang/perl/perl-5.26.9999.ebuild b/dev-lang/perl/perl-5.26.9999.ebuild
index 66819aba4188..6fcefc8a381a 100644
--- a/dev-lang/perl/perl-5.26.9999.ebuild
+++ b/dev-lang/perl/perl-5.26.9999.ebuild
@@ -15,19 +15,22 @@ if [[ "${PV##*.}" == "9999" ]]; then
# Include more versions for blead releases
# for circular reasons
# Greatest first, don't include yourself
- PERL_BIN_OLDVERSEN="5.25.11"
+ PERL_BIN_OLDVERSEN=""
PERL_OLDVERSEN="5.25.11 5.24.2 5.24.1 5.24.0 5.22.3 5.22.2 5.22.1 5.22.0"
DIST_VERSION=5.25.12
SHORT_PV="${DIST_VERSION%.*}"
+ # Devel Releases are not ABI-intercompatible
+ SUBSLOT="${DIST_VERSION}"
MY_P="perl-${DIST_VERSION/_rc/-RC}"
PATCH_BASE="perl-5.25.11-patches-${PATCH_VER}"
MY_PV="${DIST_VERSION%_rc*}"
else
- PERL_BIN_OLDVERSEN="5.25.11"
+ PERL_BIN_OLDVERSEN=""
# Compat reasons
PERL_OLDVERSEN="5.25.11"
# First 2 digits only
SHORT_PV="${PV%.*}"
+ SUBSLOT="${SHORT_PV}"
MY_P="perl-${PV/_rc/-RC}"
PATCH_BASE="${MY_P}-patches-${PATCH_VER}"
MY_PV="${PV%_rc*}"
@@ -46,7 +49,7 @@ SRC_URI="
HOMEPAGE="http://www.perl.org/"
LICENSE="|| ( Artistic GPL-1+ )"
-SLOT="0/${SHORT_PV}"
+SLOT="0/${SUBSLOT}"
if [[ "${PV##*.}" != "9999" ]]; then
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"