summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Fore <csfore@posteo.net>2023-12-06 10:09:39 -0500
committerSam James <sam@gentoo.org>2024-01-20 11:48:32 +0000
commite85be751c4ed80c056dfe7e1bde1441bcea07d5d (patch)
treea0388df82e008dd610c40582ee670802bbe27e8b
parentnet-analyzer/shodan: add 1.30.1 (diff)
downloadgentoo-e85be751c4ed80c056dfe7e1bde1441bcea07d5d.tar.gz
gentoo-e85be751c4ed80c056dfe7e1bde1441bcea07d5d.tar.bz2
gentoo-e85be751c4ed80c056dfe7e1bde1441bcea07d5d.zip
app-office/gnucash: add algorithm patch to 5.3
GCC 14 no longer includes <algorithm> by default, this will add a patch that will include it. Upstream's already accepted it and the patch should no longer be needed in 5.5. Upstream bug: https://bugs.gnucash.org/show_bug.cgi?id=799134 Closes: https://bugs.gentoo.org/917598 Signed-off-by: Christopher Fore <csfore@posteo.net> Closes: https://github.com/gentoo/gentoo/pull/34013 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-office/gnucash/files/gnucash-5.3-include-algorithm.patch12
-rw-r--r--app-office/gnucash/gnucash-5.3.ebuild3
2 files changed, 15 insertions, 0 deletions
diff --git a/app-office/gnucash/files/gnucash-5.3-include-algorithm.patch b/app-office/gnucash/files/gnucash-5.3-include-algorithm.patch
new file mode 100644
index 000000000000..d9998c8c66ed
--- /dev/null
+++ b/app-office/gnucash/files/gnucash-5.3-include-algorithm.patch
@@ -0,0 +1,12 @@
+diff --git a/libgnucash/engine/gnc-option-impl.hpp b/libgnucash/engine/gnc-option-impl.hpp
+index 4ebaa36..4d157d5 100644
+--- a/libgnucash/engine/gnc-option-impl.hpp
++++ b/libgnucash/engine/gnc-option-impl.hpp
+@@ -49,6 +49,7 @@
+ #include <variant>
+ #include <iostream>
+ #include <limits>
++#include <algorithm>
+
+ #include "gnc-option-uitype.hpp"
+
diff --git a/app-office/gnucash/gnucash-5.3.ebuild b/app-office/gnucash/gnucash-5.3.ebuild
index 9767e2a6665a..e8c2e7d7026e 100644
--- a/app-office/gnucash/gnucash-5.3.ebuild
+++ b/app-office/gnucash/gnucash-5.3.ebuild
@@ -108,6 +108,9 @@ PATCHES=(
# This is only to prevent webkit2gtk-4 from being selected.
# https://bugs.gentoo.org/893676
"${FILESDIR}/${PN}-5.0-webkit2gtk-4.1.patch"
+
+ # GCC 14 no longer includes <algorithm> by default, this is fixed in 5.5
+ "${FILESDIR}/${PN}-5.3-include-algorithm.patch"
)
# guile generates ELF files without use of C or machine code