summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-21 11:53:28 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-21 11:54:16 +0200
commite867a60db788926c07ec393229777c03c7c24018 (patch)
treed4c0318f308f6be64f85255add1e3997253e2fb0
parentdev-python/unearth: Add GH remote-id (diff)
downloadgentoo-e867a60db788926c07ec393229777c03c7c24018.tar.gz
gentoo-e867a60db788926c07ec393229777c03c7c24018.tar.bz2
gentoo-e867a60db788926c07ec393229777c03c7c24018.zip
dev-python/urllib3: Use pytest-rerunfailures to fight flakiness
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/urllib3/urllib3-2.0.5.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/dev-python/urllib3/urllib3-2.0.5.ebuild b/dev-python/urllib3/urllib3-2.0.5.ebuild
index 9a53866c278c..c19270adc8b6 100644
--- a/dev-python/urllib3/urllib3-2.0.5.ebuild
+++ b/dev-python/urllib3/urllib3-2.0.5.ebuild
@@ -38,6 +38,7 @@ BDEPEND="
dev-python/brotlicffi[\${PYTHON_USEDEP}]
dev-python/freezegun[\${PYTHON_USEDEP}]
dev-python/pytest[\${PYTHON_USEDEP}]
+ dev-python/pytest-rerunfailures[\${PYTHON_USEDEP}]
>=dev-python/tornado-4.2.1[\${PYTHON_USEDEP}]
>=dev-python/trustme-0.5.3[\${PYTHON_USEDEP}]
>=dev-python/zstandard-0.18.0[\${PYTHON_USEDEP}]
@@ -79,5 +80,6 @@ python_test() {
# plugins make tests slower, and more fragile
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest
+ # some tests are very fragile to timing
+ epytest -p rerunfailures --reruns=10 --reruns-delay=2
}