summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2018-10-04 02:39:29 +0300
committerMart Raudsepp <leio@gentoo.org>2018-10-04 02:39:36 +0300
commite8692248e147fcb304591f3abdfec574b17f3de2 (patch)
tree7297d744fac3a2c7d5028166e4da980b3fe55f2c
parentmedia-sound/bristol: Drop old (diff)
downloadgentoo-e8692248e147fcb304591f3abdfec574b17f3de2.tar.gz
gentoo-e8692248e147fcb304591f3abdfec574b17f3de2.tar.bz2
gentoo-e8692248e147fcb304591f3abdfec574b17f3de2.zip
media-libs/gst-plugins-good: bump to 1.14.4 for MKV MSE fixes (YouTube)
Signed-off-by: Mart Raudsepp <leio@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.11
-rw-r--r--media-libs/gst-plugins-good/Manifest1
-rw-r--r--media-libs/gst-plugins-good/gst-plugins-good-1.14.4.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/media-libs/gst-plugins-good/Manifest b/media-libs/gst-plugins-good/Manifest
index 9a2e1aa91671..9fa13a531a68 100644
--- a/media-libs/gst-plugins-good/Manifest
+++ b/media-libs/gst-plugins-good/Manifest
@@ -2,3 +2,4 @@ DIST gst-plugins-good-0.10.31.tar.xz 2738016 BLAKE2B a015ef6993078f1c699badcc991
DIST gst-plugins-good-1.14.1.tar.xz 3776168 BLAKE2B 5b17ac49d5bae423ee887f1516ba8bfb542acb17e3f304f489dddbaa728761ee51a08e67bd10a9981f53b5b8424d8013d1723fcbbf6e06d34a39548868d34f85 SHA512 b52d3214f2d32f263637cb9f0838284483e15b8d20bf36d64c349e99b481095734a4dd2c2421176540dfe5129ecc1acc101b89cc898b4773f0f736e8e962b070
DIST gst-plugins-good-1.14.2.tar.xz 3779912 BLAKE2B d49f82a6be7423d233ec15660470533d6bfc5da3d2ac5912ce7b3f97739b1540424c02593aff269aae3df7c6f15ca37b2d9d45fe85f3b36b910cdac4ba98f093 SHA512 26ff40d949ab95043ed717350fb344a616c72b049cd52c3e7debd9cc37f73eb9d4704b4f437ba257cecb9dba702ce451647279cb821e9405b36210b46ae9aa05
DIST gst-plugins-good-1.14.3.tar.xz 3790052 BLAKE2B 14f4116ce3eeb20f1f2cc8e835e46a9444ef82291aad90b74e74d0e79c1974bb6f2373f79543a3a3235773c954bd9def67a9e6c64522035fa65e1541695d34e1 SHA512 1077d4ac7332a4bfd58fe5be53104e1404c3a688769520650c030488a184e64a43b301fc1f1d687de668143f849a23cb0ba2b417cf284d20710b9cf32d792e45
+DIST gst-plugins-good-1.14.4.tar.xz 3792524 BLAKE2B 4c7faac73d33bebe1fd53dc4cfed1a5d27b103f9c4cd801672ad52e385f09addb07cd4a0f511dff23815e3421e5202fb3d7866b7dd58fdaf101d0357c4fdc13f SHA512 30aeb3bb74571287cad1598973da38e7a43a0128d35480ded6d280c1373dc4ecd4ea76caaa04a71cdfba2e1850aee5f1b72d96be86ae92d66633e7d32081c504
diff --git a/media-libs/gst-plugins-good/gst-plugins-good-1.14.4.ebuild b/media-libs/gst-plugins-good/gst-plugins-good-1.14.4.ebuild
new file mode 100644
index 000000000000..64330fc1aeec
--- /dev/null
+++ b/media-libs/gst-plugins-good/gst-plugins-good-1.14.4.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GST_ORG_MODULE="gst-plugins-good"
+
+inherit flag-o-matic gstreamer
+
+DESCRIPTION="Basepack of plugins for GStreamer"
+HOMEPAGE="https://gstreamer.freedesktop.org/"
+
+LICENSE="LGPL-2.1+"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="+orc"
+
+RDEPEND="
+ >=dev-libs/glib-2.40.0:2[${MULTILIB_USEDEP}]
+ >=media-libs/gst-plugins-base-${PV}:${SLOT}[${MULTILIB_USEDEP}]
+ >=media-libs/gstreamer-${PV}:${SLOT}[${MULTILIB_USEDEP}]
+ >=app-arch/bzip2-1.0.6-r4[${MULTILIB_USEDEP}]
+ >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
+ orc? ( >=dev-lang/orc-0.4.17[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.12
+"
+
+multilib_src_configure() {
+ # Always enable optional bz2 support for matroska
+ # Always enable optional zlib support for qtdemux and matroska
+ # Many media files require these to work, as some container headers are often
+ # compressed, bug #291154
+ gstreamer_multilib_src_configure \
+ --enable-bz2 \
+ --enable-zlib \
+ --disable-examples \
+ --with-default-audiosink=autoaudiosink \
+ --with-default-visualizer=goom
+
+ if multilib_is_native_abi; then
+ ln -s "${S}"/docs/plugins/html docs/plugins/html || die
+ fi
+
+}
+
+multilib_src_install_all() {
+ DOCS="AUTHORS ChangeLog NEWS README RELEASE"
+ einstalldocs
+ find "${ED}" -name '*.la' -delete || die
+}