summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2023-07-17 20:11:07 +0200
committerThomas Beierlein <tomjbe@gentoo.org>2023-07-17 20:11:07 +0200
commite871733e49602638f64e4b9a3f1c404701e24543 (patch)
tree6e9277081ad43e07bd3418e8012c519d7baa0aac
parentdev-python/ytmusicapi: Remove old (diff)
downloadgentoo-e871733e49602638f64e4b9a3f1c404701e24543.tar.gz
gentoo-e871733e49602638f64e4b9a3f1c404701e24543.tar.bz2
gentoo-e871733e49602638f64e4b9a3f1c404701e24543.zip
sci-libs/pyshp: Use PEP517 build
Closes: https://bugs.gentoo.org/910027 Signed-off-by: Thomas Beierlein <tomjbe@gentoo.org>
-rw-r--r--sci-libs/pyshp/pyshp-2.3.1-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sci-libs/pyshp/pyshp-2.3.1-r1.ebuild b/sci-libs/pyshp/pyshp-2.3.1-r1.ebuild
new file mode 100644
index 000000000000..813c53e427ef
--- /dev/null
+++ b/sci-libs/pyshp/pyshp-2.3.1-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+PYTHON_COMPAT=( python3_{9..11} )
+
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Pure Python read/write support for ESRI Shapefile format"
+HOMEPAGE="https://pypi.org/project/pyshp/"
+# pypi tarballs are missing test data
+#SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/GeospatialPython/${PN}/archive/${PV}.tar.gz -> ${P}..gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ epytest test_shapefile.py -m "not network" || die
+}