summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-21 11:12:36 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-21 11:24:49 +0200
commite877bb8ae989cc8789645f75e2a8e8d0d96d52be (patch)
tree9740c60ea17765179de5274dc55f992591292941
parentdev-python/weasyprint: Force ghostscript-gpl < 9.56 (diff)
downloadgentoo-e877bb8a.tar.gz
gentoo-e877bb8a.tar.bz2
gentoo-e877bb8a.zip
dev-python/weasyprint: Bump to 55.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/weasyprint/Manifest1
-rw-r--r--dev-python/weasyprint/weasyprint-55.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/weasyprint/Manifest b/dev-python/weasyprint/Manifest
index e5bbaf827e14..4f8a6f9e7828 100644
--- a/dev-python/weasyprint/Manifest
+++ b/dev-python/weasyprint/Manifest
@@ -1 +1,2 @@
DIST weasyprint-54.3.tar.gz 404544 BLAKE2B 52eabcab05a6806fd137648ab1a9c0cf00865f98c59a7ca43052b98b6eb54c503465285a4ceca86557a5461cd737ce9174fcda0fead08ddcd8cf632e09108bfa SHA512 4b11a2fedb2ae41b0752093a9af26c23122337ade0289e36045c2e666677f2234c43f27f12d22d571365294705458c7b34f8b2656ab3d9337f145d5b0292e92b
+DIST weasyprint-55.0.tar.gz 410970 BLAKE2B ba77f249c3568031eff9b7110864b69113f71ea197d0c7136de01bd40155a437b5e540e87219e6ca49428b98d8ec471dcf9ed1d0224d68a3b320e5fffb568239 SHA512 96cc6de5af86da47aa0b5a84c3f00679690774574f3370ca319afe77f3eb9c9725f3b0a6cbddf589f23f444972bc77b07cce7e27ee2c466484636b3cb30250a3
diff --git a/dev-python/weasyprint/weasyprint-55.0.ebuild b/dev-python/weasyprint/weasyprint-55.0.ebuild
new file mode 100644
index 000000000000..32e507b45ff5
--- /dev/null
+++ b/dev-python/weasyprint/weasyprint-55.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Visual rendering engine for HTML and CSS that can export to PDF"
+HOMEPAGE="https://weasyprint.org https://github.com/Kozea/WeasyPrint"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/cffi-0.6:=[${PYTHON_USEDEP}]
+ >=dev-python/cssselect2-0.1[${PYTHON_USEDEP}]
+ >=dev-python/fonttools-4.0.0[${PYTHON_USEDEP}]
+ >=dev-python/html5lib-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/pillow-4.0.0[jpeg,jpeg2k,${PYTHON_USEDEP}]
+ >=dev-python/pydyf-0.0.3[${PYTHON_USEDEP}]
+ >=dev-python/pyphen-0.9.1[${PYTHON_USEDEP}]
+ >=dev-python/tinycss2-1.0.0[${PYTHON_USEDEP}]
+ x11-libs/pango
+"
+
+BDEPEND="
+ test? (
+ <app-text/ghostscript-gpl-9.56
+ media-fonts/ahem
+ media-fonts/dejavu
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/addopts/d' pyproject.toml || die
+ distutils-r1_src_prepare
+}