summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-01 08:40:23 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-01 09:45:02 +0200
commite893829a9ce6c0b4201fc7b77dd4699397a0f4d9 (patch)
treeb3fd9163dc29d9d921b05d2a8d00e38349d8fece
parentdev-python/breathe: Bump to 4.29.2 (diff)
downloadgentoo-e893829a.tar.gz
gentoo-e893829a.tar.bz2
gentoo-e893829a.zip
dev-python/humanize: Bump to 3.5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/humanize/Manifest1
-rw-r--r--dev-python/humanize/humanize-3.5.0.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/humanize/Manifest b/dev-python/humanize/Manifest
index 15e0da3b0f6c..922646040025 100644
--- a/dev-python/humanize/Manifest
+++ b/dev-python/humanize/Manifest
@@ -1,2 +1,3 @@
DIST humanize-3.3.0.tar.gz 54639 BLAKE2B 7861a5e0403aa9ea047e39f9aa42fdfd7c7f38f295e93b9790f7fea3a86a57e33e65cb302165f1f962a46bf84238fc8b53b2e3e786eb1804b674dca97f959fae SHA512 a25bbaaa8cdd8fc0a7375637c19f91f892b33b8576e4c88b9adc431e976cb4f8937f1f98d71f442547626276c75cb6be445cac9b11b6504b6a444740df486faf
DIST humanize-3.4.1.tar.gz 56119 BLAKE2B 79f91e03b0c3ab1c645552ee3a0bf321e0ee620f5c0af827e44ba9995c9128638d1dc5cd80e4210de143ab55b39fb25e03abb4afaf5fa9a98973ef6c37d99b2d SHA512 d7e201717ee6b1065920faed3fa70f48c7b6acaf246a707126246d84f516fe7a14713bf4c488b18815907a0926b6cf505f106e15f17051f69756a50f50cea51b
+DIST humanize-3.5.0.tar.gz 56651 BLAKE2B 05095fbdf7c55258bf3d01c73f47bf913e1fda3e6d8a2fcf666f4d70cfd6e437071140716b9f5b6a31c02c06da1d2df6f80d5d021c279d4f97f756f41f3c3bb3 SHA512 ca04d79533b08f1549cd530fec35352696b314d6d667476bf5506a482a4ff379fe6ae021a1f338aa6837877a90e57ce032cdc671b68be34dd52e0e41aad10170
diff --git a/dev-python/humanize/humanize-3.5.0.ebuild b/dev-python/humanize/humanize-3.5.0.ebuild
new file mode 100644
index 000000000000..7bc5554aa175
--- /dev/null
+++ b/dev-python/humanize/humanize-3.5.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Common humanization utilities"
+HOMEPAGE="https://github.com/jmoiron/humanize/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? ( dev-python/freezegun[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests --install pytest