summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-09-07 20:46:45 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2023-09-07 20:46:45 +0300
commite8a08ea9c614f52b9936ec3089d59839948961cd (patch)
tree223dab205c9d0ea01aa222004efcd3d3389803d7
parentdev-python/ypy-websocket: add 0.12.3 (diff)
downloadgentoo-e8a08ea9c614f52b9936ec3089d59839948961cd.tar.gz
gentoo-e8a08ea9c614f52b9936ec3089d59839948961cd.tar.bz2
gentoo-e8a08ea9c614f52b9936ec3089d59839948961cd.zip
dev-python/userpath: add 1.9.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/userpath/Manifest1
-rw-r--r--dev-python/userpath/userpath-1.9.1.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/userpath/Manifest b/dev-python/userpath/Manifest
index 9f681a96220b..69251b5dbdbe 100644
--- a/dev-python/userpath/Manifest
+++ b/dev-python/userpath/Manifest
@@ -1 +1,2 @@
DIST userpath-1.9.0.gh.tar.gz 11090 BLAKE2B 70eac3d629c71604047d9dfa4eaf2eeb90011d0b943367aacc0e4e1efb7d45de0efb8075404510e791bd8da3609423d29503101943edc108aa012e8018e53b63 SHA512 a5683a7423465426debda02d58b2f5ef8d17d38d2fac2378cdf3075a2a6f0b7d75210bb1eac30966d323ec5f25073cc9286ae1b37acaa1bf7785da02a4c40805
+DIST userpath-1.9.1.gh.tar.gz 11183 BLAKE2B 91d5eec83ec1720cf7f65f9d67bb09d86b6679fc540026ba0b7b99522bb4e062c35bb2d6d751684f3cbaa78bca5ab1e1cb34b25a937f744115a9b80096637858 SHA512 a98b000a0968f81131eb5a91822fda72bc38e6aa2b2a85be43974c37155cbf23aa2698dac1969f078bcca1ebcbc9bd5ef71e4437eae691b7358610bcc74859d5
diff --git a/dev-python/userpath/userpath-1.9.1.ebuild b/dev-python/userpath/userpath-1.9.1.ebuild
new file mode 100644
index 000000000000..e9cbe4cde968
--- /dev/null
+++ b/dev-python/userpath/userpath-1.9.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Cross-platform tool for adding locations to the user PATH"
+HOMEPAGE="
+ https://github.com/ofek/userpath/
+ https://pypi.org/project/userpath/
+"
+SRC_URI="
+ https://github.com/ofek/userpath/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/click[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest