summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conrad@kostecki.com>2018-10-07 13:02:20 +0200
committerVirgil Dupras <vdupras@gentoo.org>2018-10-11 14:12:32 -0400
commite8a8e22890881d806f95de192e5f79e6c708f584 (patch)
tree0b0cc6f70072ceed89d5c528b71e5c8838610b6e
parentmedia-tv/kodi: dependency improvements (diff)
downloadgentoo-e8a8e22890881d806f95de192e5f79e6c708f584.tar.gz
gentoo-e8a8e22890881d806f95de192e5f79e6c708f584.tar.bz2
gentoo-e8a8e22890881d806f95de192e5f79e6c708f584.zip
dev-lang/mono-basic: restrict tests and bump to EAPI=7
Tests do need internet access, so network-sandbox must be disabled. But tests also seems to fail. No response from upstream. Closes: https://bugs.gentoo.org/656682 Closes: https://bugs.gentoo.org/655900 Signed-off-by: Conrad Kostecki <conrad@kostecki.com> Package-Manager: Portage-2.3.50, Repoman-2.3.11 Closes: https://github.com/gentoo/gentoo/pull/10024 Signed-off-by: Virgil Dupras <vdupras@gentoo.org>
-rw-r--r--dev-lang/mono-basic/mono-basic-4.6-r2.ebuild18
-rw-r--r--dev-lang/mono-basic/mono-basic-4.7-r1.ebuild18
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-lang/mono-basic/mono-basic-4.6-r2.ebuild b/dev-lang/mono-basic/mono-basic-4.6-r2.ebuild
new file mode 100644
index 000000000000..9a28161ec719
--- /dev/null
+++ b/dev-lang/mono-basic/mono-basic-4.6-r2.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit mono-env
+
+DESCRIPTION="Visual Basic Compiler and Runtime"
+HOMEPAGE="https://www.mono-project.com/docs/about-mono/languages/visualbasic/"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="LGPL-2 MIT"
+SLOT="0"
+
+RDEPEND="dev-lang/mono"
+DEPEND="${RDEPEND}"
+
+RESTRICT="test"
diff --git a/dev-lang/mono-basic/mono-basic-4.7-r1.ebuild b/dev-lang/mono-basic/mono-basic-4.7-r1.ebuild
new file mode 100644
index 000000000000..9a28161ec719
--- /dev/null
+++ b/dev-lang/mono-basic/mono-basic-4.7-r1.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit mono-env
+
+DESCRIPTION="Visual Basic Compiler and Runtime"
+HOMEPAGE="https://www.mono-project.com/docs/about-mono/languages/visualbasic/"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="LGPL-2 MIT"
+SLOT="0"
+
+RDEPEND="dev-lang/mono"
+DEPEND="${RDEPEND}"
+
+RESTRICT="test"