summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-03-25 02:54:01 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-03-25 03:27:23 +0100
commite8b51c8b560210b83356f5379eb34ffc2303653e (patch)
tree7eadb9fd0c515a68494551bdad78f8fadd86a3e9
parentapp-emacs/transient: bump to 0.6.0 (diff)
downloadgentoo-e8b51c8b560210b83356f5379eb34ffc2303653e.tar.gz
gentoo-e8b51c8b560210b83356f5379eb34ffc2303653e.tar.bz2
gentoo-e8b51c8b560210b83356f5379eb34ffc2303653e.zip
app-emacs/transient: sync live 9999 version
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--app-emacs/transient/transient-9999.ebuild16
1 files changed, 10 insertions, 6 deletions
diff --git a/app-emacs/transient/transient-9999.ebuild b/app-emacs/transient/transient-9999.ebuild
index adb9d5ff1a85..02944ca13d21 100644
--- a/app-emacs/transient/transient-9999.ebuild
+++ b/app-emacs/transient/transient-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -9,23 +9,27 @@ DESCRIPTION="Transient commands abstraction for GNU Emacs"
HOMEPAGE="https://magit.vc/manual/transient/
https://github.com/magit/transient/"
-if [[ ${PV} == *9999* ]] ; then
+if [[ "${PV}" == *9999* ]] ; then
inherit git-r3
+
EGIT_REPO_URI="https://github.com/magit/${PN}.git"
else
SRC_URI="https://github.com/magit/${PN}/archive/v${PV}.tar.gz
-> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
fi
LICENSE="GPL-3+"
SLOT="0"
-DOCS=( CHANGELOG README.org docs/${PN}.org )
+DOCS=( CHANGELOG README.org "docs/${PN}.org" )
ELISP_TEXINFO="docs/${PN}.texi"
SITEFILE="50${PN}-gentoo.el"
-RDEPEND=">=app-emacs/compat-29.1.4.1"
+RDEPEND="
+ >=app-emacs/compat-29.1.4.1
+"
BDEPEND="
${RDEPEND}
sys-apps/texinfo
@@ -34,5 +38,5 @@ BDEPEND="
src_prepare() {
mv lisp/*.el . || die
- default
+ elisp_src_prepare
}