summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-02-10 02:54:24 +0000
committerSam James <sam@gentoo.org>2024-02-10 03:16:31 +0000
commite8b635c078926a82d2605da1bc09b9aa19570a2c (patch)
treeb1da1beebacd8a16c8814957833d3d7822ee6a25
parentdev-python/re-assert: disable pypy3 b/c of dev-python/regex (diff)
downloadgentoo-e8b635c078926a82d2605da1bc09b9aa19570a2c.tar.gz
gentoo-e8b635c078926a82d2605da1bc09b9aa19570a2c.tar.bz2
gentoo-e8b635c078926a82d2605da1bc09b9aa19570a2c.zip
dev-python/lark: only depend on dev-python/regex for tests w/o pypy
The tests cleanly skip if dev-python/regex isn't available. Also, while at it, clean up <py3.10-era skip. Bug: https://bugs.gentoo.org/924136 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-python/lark/lark-1.1.9.ebuild12
1 files changed, 4 insertions, 8 deletions
diff --git a/dev-python/lark/lark-1.1.9.ebuild b/dev-python/lark/lark-1.1.9.ebuild
index 140ffaaa34e1..302e7201818e 100644
--- a/dev-python/lark/lark-1.1.9.ebuild
+++ b/dev-python/lark/lark-1.1.9.ebuild
@@ -18,10 +18,13 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~arm64-macos ~x64-macos"
+# dev-python/regex doesn't support pypy
BDEPEND="
test? (
dev-python/atomicwrites[${PYTHON_USEDEP}]
- dev-python/regex[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/regex[${PYTHON_USEDEP}]
+ ' 'python*')
)
"
@@ -33,12 +36,5 @@ python_test() {
tests/test_nearley/test_nearley.py
)
- if has "${EPYTHON}" pypy3 python3.{8,9}; then
- EPYTEST_IGNORE+=(
- # test using Python 3.10+ syntax
- tests/test_pattern_matching.py
- )
- fi
-
epytest
}