summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-17 09:23:59 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-17 10:30:58 +0200
commite8b80ee098712f0b5caa8fdccd354cc0bf1cd510 (patch)
tree34a40beaf4eff95b76fdcaa39d2af1717c5f607e
parentdev-python/pytest-rerunfailures: Bump to 10.2 (diff)
downloadgentoo-e8b80ee0.tar.gz
gentoo-e8b80ee0.tar.bz2
gentoo-e8b80ee0.zip
dev-python/botocore: Bump to 1.21.43
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.21.43.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 32a7894381c5..7889f12c5053 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -2,3 +2,4 @@ DIST botocore-1.21.28.tar.gz 8079306 BLAKE2B 26dce445746a9da1b0cf62b622597396f9b
DIST botocore-1.21.40.tar.gz 8149052 BLAKE2B 0554e2b9caa08b7518f1b51b5a980d98926782f0d4d523fa5c40dc66ecdf2db75719a36a2bf320c8d473119030693e0d1ab6bc7ea34c0574de7488bff5d7e411 SHA512 5466e15f8c09f3b4df13aee951d65219be86ccf1c0e73ed17e50fb7e2418f4694409676804bf6cf3ca638419512d903708e0994cff1f8105a19f0e26f0cabc31
DIST botocore-1.21.41.tar.gz 8152451 BLAKE2B e236a8f0f64bd18c138dc168c74cefe7af598ad72def9e1faeba222b07f01a65fb7f74627afe470f2894794fd3a617aaa1d789a983606de9329db58c5db2d975 SHA512 540848ccb054340f22c20930a3f867754accd15c6f084dd20ca97184d1c5e390d68f21272d68087b99ae6676d05cbc187e61c88dd0df09cc033e01f1ac1af0ac
DIST botocore-1.21.42.tar.gz 8156403 BLAKE2B 199d1eeae7b51fc59b8ca6ed3ea331178e94354841144f0055f02a9cd3d67e2bf52c358a7902090bc555c96e6876dcda1b4fe9b9c5c090ce07901af60b4ed116 SHA512 5be1b82f99ea310077bef3abbca6542a1787db38d5f2004107ff2c4b51a57e39e859116daf9451b23368347e05cded84a401476ca6e3fcd13683e4fc8ceb8554
+DIST botocore-1.21.43.tar.gz 8167256 BLAKE2B 525f0d1e7cacd34d81800abf5a120cdaff2a5ba91dfe7e7405d54d8b1768b45df4b1d36b287ab1db42ad68f17f1f2bfcd5c71c64a270824c69128fafea8ec113 SHA512 709f1792f855bb4178dd2d1e79f7b476e5b695a84684d9a5e6e57a36bd8f881f28cc4322a2e296c3935fad544d6adb4ede15a7cd532c7e5671350f0d96bee105
diff --git a/dev-python/botocore/botocore-1.21.43.ebuild b/dev-python/botocore/botocore-1.21.43.ebuild
new file mode 100644
index 000000000000..30e0988848ad
--- /dev/null
+++ b/dev-python/botocore/botocore-1.21.43.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+ # very unstable
+ sed -i -e 's:test_stress_test_token_bucket:_&:' \
+ tests/functional/retries/test_bucket.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # note: suites need to be run separately as one of the unit tests
+ # seems to be leaking mocks and breaking a few functional tests
+ nosetests -v tests/unit ||
+ die "unit tests failed under ${EPYTHON}"
+ nosetests -v tests/functional ||
+ die "functional tests failed under ${EPYTHON}"
+}