summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-28 09:34:19 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-28 09:36:29 +0100
commite8dd0407404553f70b0021f0be577cf5c8dd683b (patch)
tree02ae81952275b6fc39c212a54cd594bf892cb189
parentdev-python/jaraco-logging: Bump to 3.1.0 (diff)
downloadgentoo-e8dd0407404553f70b0021f0be577cf5c8dd683b.tar.gz
gentoo-e8dd0407404553f70b0021f0be577cf5c8dd683b.tar.bz2
gentoo-e8dd0407404553f70b0021f0be577cf5c8dd683b.zip
dev-python/jaraco-collections: Bump to 3.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/jaraco-collections/Manifest1
-rw-r--r--dev-python/jaraco-collections/jaraco-collections-3.1.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/jaraco-collections/Manifest b/dev-python/jaraco-collections/Manifest
index 8a812fbe2520..60dae7e2fbd7 100644
--- a/dev-python/jaraco-collections/Manifest
+++ b/dev-python/jaraco-collections/Manifest
@@ -1 +1,2 @@
DIST jaraco.collections-3.0.0.tar.gz 16439 BLAKE2B ff3690d85d91da8d88945e9ab8d16d13c7d0f67a9334f706701f9b392d8cffdd9450b2d6051a92799564cfc81310e45f50368ab729a0b68c08a9c8b0ccd9627d SHA512 c6c5d28fe4b3940c81c68bf877249805db3f508d83a0071947c7a5596d3636631df91cc6e87802b0fa6cd5c8bdd1ef2f39b924471666b44d2147cb64ad1533ad
+DIST jaraco.collections-3.1.0.tar.gz 18206 BLAKE2B c420b3c65c048840f2957ebff0e69a7e2d3db515801a54d829bc2dd9f77b804066ef15766c915b764a148eaa945fc9a30576bb00a645f4c124c031b6ccc64184 SHA512 9a3e4e60cd497ee2ed4a092bd823ecffe0d20293dd9ba491fd2c4e5df2481042efa8ba52503b001e11908982608852a0588cd70b4957d0551c066be97389652c
diff --git a/dev-python/jaraco-collections/jaraco-collections-3.1.0.ebuild b/dev-python/jaraco-collections/jaraco-collections-3.1.0.ebuild
new file mode 100644
index 000000000000..57a148e6aa8a
--- /dev/null
+++ b/dev-python/jaraco-collections/jaraco-collections-3.1.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+inherit distutils-r1
+
+MY_PN="${PN/-/.}"
+DESCRIPTION="Models and classes to supplement the stdlib collections module"
+HOMEPAGE="https://github.com/jaraco/jaraco.collections"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86"
+
+RDEPEND="
+ dev-python/jaraco-classes[${PYTHON_USEDEP}]
+ dev-python/jaraco-text[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
+"
+
+PATCHES=(
+ "${FILESDIR}/jaraco-collections-3.0.0-pypy.patch"
+)
+
+distutils_enable_sphinx docs '>=dev-python/jaraco-packaging-3.2' \
+ '>=dev-python/rst-linker-1.9'
+distutils_enable_tests pytest
+
+python_test() {
+ # Override pytest options to skip flake8
+ PYTHONPATH=. pytest -vv --override-ini="addopts=--doctest-modules" \
+ || die "tests failed with ${EPYTHON}"
+}
+
+# https://wiki.gentoo.org/wiki/Project:Python/Namespace_packages#File_collisions_between_pkgutil-style_packages
+python_install() {
+ rm "${BUILD_DIR}"/lib/jaraco/__init__.py || die
+ # note: eclass may default to --skip-build in the future
+ distutils-r1_python_install --skip-build
+}