summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-11-30 05:09:51 +0000
committerSam James <sam@gentoo.org>2022-11-30 05:09:51 +0000
commite8fa0139c9d04403a711cb5707637627c0673717 (patch)
tree0cde8a199600e0f53911b6bfe77b69b13f301d10
parentdev-python/Levenshtein: Keyword 0.20.8 ia64, #873814 (diff)
downloadgentoo-e8fa0139c9d04403a711cb5707637627c0673717.tar.gz
gentoo-e8fa0139c9d04403a711cb5707637627c0673717.tar.bz2
gentoo-e8fa0139c9d04403a711cb5707637627c0673717.zip
dev-perl/Curses: add 1.410.0
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-perl/Curses/Curses-1.410.0.ebuild47
-rw-r--r--dev-perl/Curses/Manifest1
-rw-r--r--dev-perl/Curses/files/Curses-1.410.0-clang16.patch84
3 files changed, 132 insertions, 0 deletions
diff --git a/dev-perl/Curses/Curses-1.410.0.ebuild b/dev-perl/Curses/Curses-1.410.0.ebuild
new file mode 100644
index 000000000000..09e5023669bd
--- /dev/null
+++ b/dev-perl/Curses/Curses-1.410.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=GIRAFFED
+DIST_VERSION=1.41
+DIST_EXAMPLES=("demo" "demo2" "demo.form" "demo.menu" "demo.panel")
+inherit perl-module toolchain-funcs
+
+DESCRIPTION="Curses interface modules for Perl"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~sparc-solaris ~x86-solaris"
+IUSE="+unicode"
+
+RDEPEND="
+ >=sys-libs/ncurses-6:=[unicode(+)?]
+ virtual/perl-Data-Dumper
+"
+DEPEND="
+ >=sys-libs/ncurses-6:=[unicode(+)?]
+"
+BDEPEND="
+ ${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( virtual/perl-Test-Simple )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.410.0-clang16.patch
+)
+
+src_configure() {
+ myconf=( FORMS PANELS MENUS )
+ mydoc=( HISTORY )
+
+ export CURSES_LIBTYPE="$(usex unicode ncursesw ncurses)"
+ export CURSES_LDFLAGS=$($(tc-getPKG_CONFIG) --libs ${CURSES_LIBTYPE})
+ export CURSES_CFLAGS=$($(tc-getPKG_CONFIG) --cflags ${CURSES_LIBTYPE})
+
+ perl-module_src_configure
+
+ if ! use unicode ; then
+ sed -i 's:<form.h>:"${ESYSROOT}/usr/include/form.h":' "${S}"/c-config.h || die
+ fi
+}
diff --git a/dev-perl/Curses/Manifest b/dev-perl/Curses/Manifest
index 66499d4511a5..56d0bf347996 100644
--- a/dev-perl/Curses/Manifest
+++ b/dev-perl/Curses/Manifest
@@ -1,2 +1,3 @@
DIST Curses-1.37.tar.gz 135763 BLAKE2B b42f81d5a382b8cf6c8323cc5c13fd39dcc57081ad2e3de9e940f06a0126879d301ccaebc5c34fb5cb4bffd1263b0681243164539c450db50cd3388e6fd35823 SHA512 10886e725b174fdabc0c9b86a9ef9b717949f0fb03561bfc315e8503be689be7945d1ceeea2f950628ce480c2cc8081736d3b8f28042ea677b252298a9eb4827
DIST Curses-1.38.tar.gz 135789 BLAKE2B 68817bfafcfe2b9d9480c12f2490f9281b5e0cc51bbcfd795e2728a21ef24e12362cfc0896d7b5d6678f35f25fb80c0aee4cde5cf06ec8b3871168cd059649d6 SHA512 27999e71f19576c930a794c9f478e8a3b6b3b1d1e68c4ca57b712f20c98a83dba46295c012a6c618d097b661ec30441c8147e26579218ecef977d7c7996c7442
+DIST Curses-1.41.tar.gz 137458 BLAKE2B 04cb8fc655d0f8ce629fad453923a82ee8c3f7b95e042f036b1c1dc6781e181c04716f8166ebfc0a34eab2402271e8e05ce9438af7a7276c11d22fd9106733f7 SHA512 a8d091f3f79be6368bb0e465563cc736a934f66f489d8c1ec86dca71c22705c7969e1468c9d330cc6653994af550f8f95282b0fd504174d2f77b7d32e98be108
diff --git a/dev-perl/Curses/files/Curses-1.410.0-clang16.patch b/dev-perl/Curses/files/Curses-1.410.0-clang16.patch
new file mode 100644
index 000000000000..1f11a893b2d4
--- /dev/null
+++ b/dev-perl/Curses/files/Curses-1.410.0-clang16.patch
@@ -0,0 +1,84 @@
+Fedora sent upstream by email: https://bugzilla.redhat.com/show_bug.cgi?id=2148432#c2.
+
+https://src.fedoraproject.org/rpms/perl-Curses/c/2633f3adcd14dff61d6d45f97c8bc4f65ce06d82?branch=rawhide
+Add missing int types for C99 compatibility.
+--- a/testint.c
++++ b/testint.c
+@@ -8,6 +8,7 @@
+
+ #include "c-config.h"
+
++int
+ main() {
+ int ret;
+
+--- a/testtyp.c
++++ b/testtyp.c
+@@ -8,6 +8,7 @@
+
+ #include "c-config.h"
+
++int
+ main() {
+ typedef SYM c_sym_t;
+ }
+
+--- a/test.syms
++++ b/test.syms
+@@ -24,6 +24,9 @@ use warnings;
+ use English;
+
+ my $verbose;
++my $panels;
++my $menus;
++my $forms;
+
+ sub makeCompileCommand($) {
+ my ($compileR) = @_;
+@@ -74,22 +77,31 @@ sub makeCompileCommand($) {
+ #
+ # _C_SYM_ and _C_FILE_ will be filled in later
+
++ my $defs_prefix = '-D';
+ if ($OSNAME =~ m{VMS}i) {
+- $compile =~ s{#DEFS#}{DEFINE=SYM="_C_SYM_"};
++ $defs_prefix = 'DEFINE-';
+ $compile =~ s{#FILE#}{_C_FILE_.c};
+ $compile =~ s{#NULL#}{}; # no non-verbose way
+ }
+ elsif ($OSNAME eq 'MSWin32') {
+- $compile =~ s{#DEFS#}{-DSYM="_C_SYM_"};
+ $compile =~ s{#FILE#}{_C_FILE_.c};
+ $compile =~ s{#NULL#}{>nul 2>&1};
+ }
+ else {
+- $compile =~ s{#DEFS#}{-DSYM="_C_SYM_"};
+ $compile =~ s{#FILE#}{-o _C_FILE_ _C_FILE_.c};
+ $compile =~ s{#NULL#}{>/dev/null 2>&1};
+ }
+
++ # Make these defines from CursesDef.h available early, so that
++ # the feature probing uses the correct build configuration.
++ my @defs = (qq(${defs_prefix}SYM="_C_SYM_"));
++ push @defs, qq(${defs_prefix}C_PANELFUNCTION="1") if $panels;
++ push @defs, qq(${defs_prefix}C_MENUFUNCTION="1") if $menus;
++ push @defs, qq(${defs_prefix}C_FORMFUNCTION="1") if $forms;
++
++ $compile =~ s{#DEFS#}{join " ", @defs}e;
++
++
+ if ($compile =~ m{#.+#}) {
+ die "OOPS: internal error constructing a compile command. " .
+ "We failed to substitute for a #xxx# substitution variable " .
+@@ -109,10 +121,6 @@ print("Set CURSES_VERBOSE environment variable to see the details of the " .
+ "tests.\n");
+ print("\n");
+
+-my $panels;
+-my $menus;
+-my $forms;
+-
+ if ($ENV{CURSES_VERBOSE}) {
+ $verbose = 1;
+ } else {
+