summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2018-05-28 12:17:25 -0400
committerAaron Bauman <bman@gentoo.org>2018-05-28 19:01:57 -0400
commite9086f3acbab5f6715a46323c5c16a1d357e81c8 (patch)
tree28de4460c6cfd429c4c80cfb94ece61bd5935ba7
parentnet-misc/gofish: bump EAPI and drop eutils (diff)
downloadgentoo-e9086f3acbab5f6715a46323c5c16a1d357e81c8.tar.gz
gentoo-e9086f3acbab5f6715a46323c5c16a1d357e81c8.tar.bz2
gentoo-e9086f3acbab5f6715a46323c5c16a1d357e81c8.zip
net-misc/taptap: bump EAPI
Package-Manager: Portage-2.3.40, Repoman-2.3.9
-rw-r--r--net-misc/taptap/taptap-1.0.ebuild11
1 files changed, 4 insertions, 7 deletions
diff --git a/net-misc/taptap/taptap-1.0.ebuild b/net-misc/taptap/taptap-1.0.ebuild
index 414b9b373c9f..f95f52794ab5 100644
--- a/net-misc/taptap/taptap-1.0.ebuild
+++ b/net-misc/taptap/taptap-1.0.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=2
+EAPI=6
inherit toolchain-funcs
DESCRIPTION="A program to link two /dev/net/tun to form virtual ethernet"
@@ -16,6 +16,7 @@ IUSE=""
S=${WORKDIR}/${PN}
src_prepare() {
+ default
sed -i \
-e 's:= -Wall -s:+= -Wall:' \
-e 's:$(CFLAGS):$(LDFLAGS) &:' \
@@ -23,9 +24,5 @@ src_prepare() {
}
src_compile() {
- emake CC="$(tc-getCC)" || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
+ emake CC="$(tc-getCC)"
}