summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2023-04-19 12:21:58 -0400
committerMike Gilbert <floppym@gentoo.org>2023-04-19 12:21:58 -0400
commite9206a75ac7a1c2dbceb1e7fe451894687a1d1e4 (patch)
treee3b00d91f2866d3e8132fc0bed5c6305027fc160
parentdev-ml/ocaml-gettext-stub: fix camomile breakage (diff)
downloadgentoo-e9206a75ac7a1c2dbceb1e7fe451894687a1d1e4.tar.gz
gentoo-e9206a75ac7a1c2dbceb1e7fe451894687a1d1e4.tar.bz2
gentoo-e9206a75ac7a1c2dbceb1e7fe451894687a1d1e4.zip
dev-util/gn: add 0.2088
Bug: https://bugs.gentoo.org/898750 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
-rw-r--r--dev-util/gn/Manifest1
-rw-r--r--dev-util/gn/gn-0.2088.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-util/gn/Manifest b/dev-util/gn/Manifest
index 30569d413f40..8b9c73cfc7b5 100644
--- a/dev-util/gn/Manifest
+++ b/dev-util/gn/Manifest
@@ -1,2 +1,3 @@
DIST gn-0.2049.tar.xz 727960 BLAKE2B fe93d09c1fa5b6267a4d26f37ec42e629b36645ef58bf6ebcc07dd8cd2ee9509c1e997182251a3e2c3ef3c5b7d636c9a8228c1e49d1d7245b3ebdac36e7c5a1a SHA512 f3e6dc87d647702c5d22793e2eed3e9950f8c9a6d7178eae67bb7d6518b6533c74fa3f43245fb9e422994a27f1a0f1986709f91e7ce2ed78eb5f17838f75e1db
DIST gn-0.2077.tar.xz 735596 BLAKE2B 48da6c1b08746d364974c94a8395708ba44f4fb88a4bd6142d8ce3935608538b3e3d316c1b3934b124bb2af8549e0bc355b4f0990ab0b794adca025a4c3db7c5 SHA512 361fa1d71f4c4ed12fec8136fb79ee8d30cd8c9b93f2d9972222e028a8b74326045f000431863c6d7ab598b1d7b06c00c95793830da48f52e623a1246bcc8bc4
+DIST gn-0.2088.tar.xz 736408 BLAKE2B 23cb932c6fa1711472e0369b5c9271dd28b1d1a8eee40366295ea576fb0d913f3e01dd802df718d6d55ad27b566b0fae5da0cb03167e38df46bbda284b26f99c SHA512 be1d0a0095a7de9fc130935d45c610ab77dd9451822b33c344ac79d096828752bab04b81183eaa35b654abbb76748ce13751c04d44968d08643b6cd89f3fe8f7
diff --git a/dev-util/gn/gn-0.2088.ebuild b/dev-util/gn/gn-0.2088.ebuild
new file mode 100644
index 000000000000..e43a47213d69
--- /dev/null
+++ b/dev-util/gn/gn-0.2088.ebuild
@@ -0,0 +1,64 @@
+# Copyright 2018-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit ninja-utils python-any-r1 toolchain-funcs
+
+DESCRIPTION="GN is a meta-build system that generates build files for Ninja"
+HOMEPAGE="https://gn.googlesource.com/"
+SRC_URI="https://dev.gentoo.org/~sultan/distfiles/dev-util/gn/${P}.tar.xz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="vim-syntax"
+
+BDEPEND="
+ ${PYTHON_DEPS}
+ dev-util/ninja
+"
+
+PATCHES=(
+ "${FILESDIR}"/gn-gen-r5.patch
+)
+
+pkg_setup() {
+ :
+}
+
+src_configure() {
+ python_setup
+ tc-export AR CC CXX
+ unset CFLAGS
+ set -- ${EPYTHON} build/gen.py --no-last-commit-position --no-strip --no-static-libstdc++ --allow-warnings
+ echo "$@" >&2
+ "$@" || die
+ cat >out/last_commit_position.h <<-EOF || die
+ #ifndef OUT_LAST_COMMIT_POSITION_H_
+ #define OUT_LAST_COMMIT_POSITION_H_
+ #define LAST_COMMIT_POSITION_NUM ${PV##0.}
+ #define LAST_COMMIT_POSITION "${PV}"
+ #endif // OUT_LAST_COMMIT_POSITION_H_
+ EOF
+}
+
+src_compile() {
+ eninja -C out gn
+}
+
+src_test() {
+ eninja -C out gn_unittests
+ out/gn_unittests || die
+}
+
+src_install() {
+ dobin out/gn
+ einstalldocs
+
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles
+ doins -r misc/vim/{autoload,ftdetect,ftplugin,syntax}
+ fi
+}