summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam Jorna <wraeth@gentoo.org>2022-08-28 14:15:18 +1000
committerSam Jorna <wraeth@gentoo.org>2022-08-28 14:15:18 +1000
commite93576f5bf0e5e429cf5620d05730898499a3132 (patch)
treeed658bdbfd38d4d36b28b9bab2f319bfe1c2ca2c
parentnet-irc/limnoria: drop 20211118 (diff)
downloadgentoo-e93576f5.tar.gz
gentoo-e93576f5.tar.bz2
gentoo-e93576f5.zip
net-irc/limnoria-plugins-chantracker: add 1.6_p20220803
Signed-off-by: Sam Jorna <wraeth@gentoo.org>
-rw-r--r--net-irc/limnoria-plugins-chantracker/Manifest1
-rw-r--r--net-irc/limnoria-plugins-chantracker/limnoria-plugins-chantracker-1.6_p20220803.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/net-irc/limnoria-plugins-chantracker/Manifest b/net-irc/limnoria-plugins-chantracker/Manifest
index 34fd6fec2364..1c651c4e3521 100644
--- a/net-irc/limnoria-plugins-chantracker/Manifest
+++ b/net-irc/limnoria-plugins-chantracker/Manifest
@@ -1,3 +1,4 @@
DIST limnoria-plugins-chantracker-1.6_p20211103.tar.gz 52922 BLAKE2B a397c4235eb0487d6e84acb8c8dabd78fe1dcd4b64a85b94168fd9be5b3cbaa32049d621348b81b026d68bc1599b7b1db2051a572258e80eb0b8be875d3c9b2a SHA512 bf1c613b1daa979e310bf566e5584004ea824a65464e1b185b58ccc45c62f052d449a25e686eb0faa9657f29ff69b89ec588cf8ea40ad4dff415b9fc02faed04
DIST limnoria-plugins-chantracker-1.6_p20220312.tar.gz 52441 BLAKE2B 539038581ed988fc64216171d293271a811561903d23badcef36124d5ee80e26e1f67ff7d0e36e463aac92bc2442bc28766116bc9f92e5f86d8e14728180e192 SHA512 9e9cee65e3d19bab2c5079348bfbd598ecc71d3d8cc11bbcf76b79f39a14c9171c2a0a5e5ea7cf5550e9ab082ab6d764205f44e47bd1ea596d81ace68ca26075
DIST limnoria-plugins-chantracker-1.6_p20220429.tar.gz 52444 BLAKE2B cbd4187b1b288402b45680a8a7ae080028e68d8409d01ef7c53ad99aae1c94336701a98fe66de29261cb12472ebc9102e31d2862c3da872fe9f55fd40b61cb0b SHA512 ff59e7f42c8fccc2214496e884ae8ef931b8e77839d898fb23fd2551bb91d1865134047fda9001892cd29b892ca4af6b959015d7e763bbeedaf7d13382af1113
+DIST limnoria-plugins-chantracker-1.6_p20220803.tar.gz 52514 BLAKE2B c6053e0c00b41ab7defeadd14bb2c740b33e51a5a2712d69a7867876c0563261444c934f6c3d58c0dab67ed2ce9839e1a3835f15ca9e744ff1468e543ecd3bc2 SHA512 d3ef76404c136c65251503418acbf9e8f9cf6125ea39e2845ccd4b8ce56faef936d5a4d780ae9aedb82b215cd4f3fa88dc51b9f8880b2fd1b9d05fe718646dad
diff --git a/net-irc/limnoria-plugins-chantracker/limnoria-plugins-chantracker-1.6_p20220803.ebuild b/net-irc/limnoria-plugins-chantracker/limnoria-plugins-chantracker-1.6_p20220803.ebuild
new file mode 100644
index 000000000000..a5dae0b018d5
--- /dev/null
+++ b/net-irc/limnoria-plugins-chantracker/limnoria-plugins-chantracker-1.6_p20220803.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vcs-snapshot
+
+COMMIT="0d257df7d63d24610462ad611555741d7655daa9"
+
+DESCRIPTION="supybot ban management and channel flood/spam/repeat protections plugin"
+HOMEPAGE="https://github.com/ncoevoet/ChanTracker"
+SRC_URI="https://github.com/ncoevoet/ChanTracker/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+SLOT=0
+
+RDEPEND="net-irc/limnoria"
+
+DOCS="README.md"
+
+src_install() {
+ default
+ insinto /usr/share/limnoria-extra-plugins/ncoevoet/ChanTracker
+ doins -r *
+}
+
+pkg_postinst() {
+ elog "Before this plugin can be used, your bot will need to be told where to"
+ elog "load it from. To do this, add /usr/share/limnoria-extra-plugins/ncoevoet when"
+ elog "prompted during the bot creation wizard, or add it to a running bots config"
+ elog "with the command"
+ elog
+ elog " config directories.plugins [config directories.plugins], /usr/share/limnoria-extra-plugins/ncoevoet"
+}