summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2020-09-17 18:06:38 -0400
committerAaron Bauman <bman@gentoo.org>2020-09-17 18:20:02 -0400
commite93890db7d319bf7cc0b9baf8f4e0a17d8817957 (patch)
tree3a5bea3b83053d6753a5f66c87290bff0a62af6b
parentdev-java/openjdk: tweak unpack & prepare phases (diff)
downloadgentoo-e93890db.tar.gz
gentoo-e93890db.tar.bz2
gentoo-e93890db.zip
package.mask: drop last-rited dev-python/notify-python
Closes: https://bugs.gentoo.org/706480 Signed-off-by: Aaron Bauman <bman@gentoo.org>
-rw-r--r--dev-python/notify-python/Manifest1
-rw-r--r--dev-python/notify-python/files/notify-python-0.1.1-libnotify-0.7.patch37
-rw-r--r--dev-python/notify-python/metadata.xml8
-rw-r--r--dev-python/notify-python/notify-python-0.1.1-r3.ebuild56
-rw-r--r--profiles/package.mask5
5 files changed, 0 insertions, 107 deletions
diff --git a/dev-python/notify-python/Manifest b/dev-python/notify-python/Manifest
deleted file mode 100644
index dc3478786ed2..000000000000
--- a/dev-python/notify-python/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST notify-python-0.1.1.tar.bz2 214514 BLAKE2B 7e7496b817abedc5577751a6525ca928c6f7e8cc51aeac810a0927e46533d93d4da73b5f76846a68cde025dae24000601a5745eb93037b149177d4941cbdaffc SHA512 67021af81d77b6a1ead4ee2a0ab4e8684c2b60c672ab7aa09a8f89d71cf646453d9be76455ac28616d70645019946db1731a7021fbb91fe66d9e057fcb3815a0
diff --git a/dev-python/notify-python/files/notify-python-0.1.1-libnotify-0.7.patch b/dev-python/notify-python/files/notify-python-0.1.1-libnotify-0.7.patch
deleted file mode 100644
index ee146cb6fd84..000000000000
--- a/dev-python/notify-python/files/notify-python-0.1.1-libnotify-0.7.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-http://pkgs.fedoraproject.org/gitweb/?p=notify-python.git;a=blob_plain;f=libnotify07.patch;hb=HEAD
-
---- src/pynotify.defs
-+++ src/pynotify.defs
-@@ -38,7 +38,6 @@
- '("const-gchar*" "summary")
- '("const-gchar*" "message" (null-ok) (default "NULL"))
- '("const-gchar*" "icon" (null-ok) (default "NULL"))
-- '("GtkWidget*" "attach" (null-ok) (default "NULL"))
- )
- )
-
-@@ -53,24 +52,6 @@
- )
- )
-
--(define-method attach_to_widget
-- (of-object "NotifyNotification")
-- (c-name "notify_notification_attach_to_widget")
-- (return-type "none")
-- (parameters
-- '("GtkWidget*" "attach")
-- )
--)
--
--(define-method attach_to_status_icon
-- (of-object "NotifyNotification")
-- (c-name "notify_notification_attach_to_status_icon")
-- (return-type "none")
-- (parameters
-- '("GtkStatusIcon*" "attach")
-- )
--)
--
- (define-method show
- (of-object "NotifyNotification")
- (c-name "notify_notification_show")
diff --git a/dev-python/notify-python/metadata.xml b/dev-python/notify-python/metadata.xml
deleted file mode 100644
index e24dd86faa2a..000000000000
--- a/dev-python/notify-python/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
-</pkgmetadata>
diff --git a/dev-python/notify-python/notify-python-0.1.1-r3.ebuild b/dev-python/notify-python/notify-python-0.1.1-r3.ebuild
deleted file mode 100644
index 733747a4582b..000000000000
--- a/dev-python/notify-python/notify-python-0.1.1-r3.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit autotools-utils eutils ltprune python-r1
-
-DESCRIPTION="Python bindings for libnotify"
-HOMEPAGE="http://www.galago-project.org/"
-SRC_URI="http://www.galago-project.org/files/releases/source/${PN}/${P}.tar.bz2"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm ~ia64 ~mips ppc ~ppc64 sparc x86"
-IUSE="examples"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="${PYTHON_DEPS}
- >=dev-python/pygtk-2.24:2[${PYTHON_USEDEP}]
- >=x11-libs/libnotify-0.7"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-PATCHES=( "${FILESDIR}"/${P}-libnotify-0.7.patch )
-
-src_prepare() {
- # Remove the old pynotify.c to ensure it's properly regenerated #212128.
- rm -f src/pynotify.c || die
- autotools-utils_src_prepare
-}
-
-src_configure() {
- python_foreach_impl autotools-utils_src_configure
-}
-
-src_compile() {
- python_foreach_impl autotools-utils_src_compile
-}
-
-src_test() {
- python_foreach_impl autotools-utils_src_test
-}
-
-src_install() {
- python_foreach_impl autotools-utils_src_install
- prune_libtool_files --all
-
- # Requested from bug 351879.
- if use examples; then
- docinto examples
- dodoc tests/*.{png,py}
- docompress -x /usr/share/doc/${PF}/examples
- fi
-}
diff --git a/profiles/package.mask b/profiles/package.mask
index 1e51b8188bc0..bd1d65df97d2 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -613,11 +613,6 @@ dev-python/pysha3
# Removal in 30 days
dev-perl/gnome2-vfs-perl
-# Michał Górny <mgorny@gentoo.org> (2020-08-17)
-# Dead pygtk-2 era library. No reverse dependencies left.
-# Removal in 30 days. Bug #706480.
-dev-python/notify-python
-
# Alfredo Tupone <tupone@gentoo.org> (2020-08-16)
# Ported to py3.8 but not yet released
# Masked to allow py2.7 removal