summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-04 04:55:45 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-04 05:01:52 +0100
commite9525b8a7518b843ef698de63a55355239fd793f (patch)
tree82905cbb1aa8e64db32172f513d59e0132a3935b
parentdev-python/python-multipart: Bump to 0.0.7 (diff)
downloadgentoo-e9525b8a7518b843ef698de63a55355239fd793f.tar.gz
gentoo-e9525b8a7518b843ef698de63a55355239fd793f.tar.bz2
gentoo-e9525b8a7518b843ef698de63a55355239fd793f.zip
dev-python/starlette: Bump to 0.36.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/starlette/Manifest1
-rw-r--r--dev-python/starlette/starlette-0.36.2.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/starlette/Manifest b/dev-python/starlette/Manifest
index 02845bf335f3..af5444fcbaed 100644
--- a/dev-python/starlette/Manifest
+++ b/dev-python/starlette/Manifest
@@ -1,2 +1,3 @@
DIST starlette-0.35.1.gh.tar.gz 2842796 BLAKE2B 1ea63f30d65103754559700eb2db699b3d03ce1dfc78081e7d2b9a680839dd0a453059d858e8b1390da2779ba755d5074033c53b5392ee7071fee27cc6739935 SHA512 75703c2ee23dd19e9c8bdd24a0a3d84f50486c0df0cad9609e0e08eb1fd3c61a4f56887d60018fbec4227bde2b3e12fb09decc865b8d5073bc4a1e066b6d5f69
DIST starlette-0.36.1.gh.tar.gz 2843494 BLAKE2B 633cd664785f32423c0dfeab04b400340b5e3197f4ef07edca9fcda20954444ccfef1ff9afc62969d5b2914f2091e08946420931ee1ee22e1ab771fe02db13ec SHA512 9a990098a1faa179bcf8df64237147d59e3114b1336f491ca358ffd0016412f18323845eb5f8691aa41810fef455e97cb47ff34d9456a0e3a5be3eb6b23027bb
+DIST starlette-0.36.2.gh.tar.gz 2843707 BLAKE2B 7ec75189d7e9864fe15823692d2d264586be8772a0ff29e1d539eb15f858ef9d77ef6398e203f5c2f8a507869026fd8863931a176923f29bf11457e58cdb66fa SHA512 fedccb1db4cfe4a0dac321c843ae211e436ec5b07c0e65b663914657a9cec61a900d95dac09b6752a51defbb310a8dce30f0867574523a3c96cf33cd19b61c76
diff --git a/dev-python/starlette/starlette-0.36.2.ebuild b/dev-python/starlette/starlette-0.36.2.ebuild
new file mode 100644
index 000000000000..31b21741ddd7
--- /dev/null
+++ b/dev-python/starlette/starlette-0.36.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=${P/_p/.post}
+DESCRIPTION="The little ASGI framework that shines"
+HOMEPAGE="
+ https://www.starlette.io/
+ https://github.com/encode/starlette/
+ https://pypi.org/project/starlette/
+"
+# no docs or tests in sdist, as of 0.27.0
+SRC_URI="
+ https://github.com/encode/starlette/archive/${PV/_p/.post}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ <dev-python/anyio-5[${PYTHON_USEDEP}]
+ >=dev-python/anyio-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/httpx-0.22.0[${PYTHON_USEDEP}]
+ dev-python/itsdangerous[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ >=dev-python/python-multipart-0.0.7[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/trio[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_IGNORE=(
+ # Unpackaged 'databases' dependency
+ tests/test_database.py
+)
+
+distutils_enable_tests pytest