summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-19 04:59:37 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-19 05:10:34 +0100
commite952c0a79d98ddfb18479cd46b38d8805922caf0 (patch)
treecd3d5b60591be8572a59820b1016a3fa6aa03119
parentdev-libs/libuv: Stabilize 1.48.0 x86, #924891 (diff)
downloadgentoo-e952c0a79d98ddfb18479cd46b38d8805922caf0.tar.gz
gentoo-e952c0a79d98ddfb18479cd46b38d8805922caf0.tar.bz2
gentoo-e952c0a79d98ddfb18479cd46b38d8805922caf0.zip
dev-python/pypdf: Bump to 4.0.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pypdf/Manifest1
-rw-r--r--dev-python/pypdf/pypdf-4.0.2.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/pypdf/Manifest b/dev-python/pypdf/Manifest
index 0777a3d24696..4a73efbf83c1 100644
--- a/dev-python/pypdf/Manifest
+++ b/dev-python/pypdf/Manifest
@@ -1,2 +1,3 @@
DIST pypdf-4.0.1.gh.tar.gz 7992979 BLAKE2B a072b50d177a89133bd5c7a74cae1d4f4ed5d6bcb1d78c68573c98f792a28a8ded26b5a82743a70ec2cd41651db8a19580cc48b0376c0dfe2f422826311914c3 SHA512 e9170b75ab00ce86580194bfa64ff3a31eb6fca62adc006478fcee3a78a99df269c75857672838c2b752b78b19174883cecb2eea5586878f81eb75474fabee6d
+DIST pypdf-4.0.2.gh.tar.gz 7992844 BLAKE2B ddd38e8c27230c6425de2677c1f2bd6f521c87e4b10e4791ed8d2b961c7c9e210b49b6d684780f16fb1620db7c123aed9ee548b381d54ae881a6e64305b26379 SHA512 4539f2c1c4b98e27dd3f43c7aa44efe03e80c8089f655130dd80dceee85afae235bc819b9309bc36653c953741ec3b998ccbb1274c28abf144792ae44147efd9
DIST pypdf-sample-files-964fb47b0fbfa89864680582640ae4eedf143890.gh.tar.gz 11668924 BLAKE2B 0c7d8e7cfb2f9d06d7633d57b691ba473d33cfcb58d2f1f83661cef9d755340d05db8767771a385d0ba88aa904f84b8bc7eafdb5d4f614b7a21a2d138572316f SHA512 28070b575273b6fee3173e797ed5bac618f8e8aca16d0122dcf3b4b16cedbcad69b84a9bc4be65037695597bcc1fa7898cdf766c37915c49f880a0c6ca057e68
diff --git a/dev-python/pypdf/pypdf-4.0.2.ebuild b/dev-python/pypdf/pypdf-4.0.2.ebuild
new file mode 100644
index 000000000000..f0cc9485cc72
--- /dev/null
+++ b/dev-python/pypdf/pypdf-4.0.2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+SAMPLE_COMMIT=964fb47b0fbfa89864680582640ae4eedf143890
+DESCRIPTION="Python library to work with PDF files"
+HOMEPAGE="
+ https://pypi.org/project/pypdf/
+ https://github.com/py-pdf/pypdf/
+"
+SRC_URI="
+ https://github.com/py-pdf/pypdf/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ test? (
+ https://github.com/py-pdf/sample-files/archive/${SAMPLE_COMMIT}.tar.gz
+ -> ${PN}-sample-files-${SAMPLE_COMMIT}.gh.tar.gz
+ )
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ >=dev-python/pillow-8.0.0[jpeg,jpeg2k,tiff,zlib,${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_unpack() {
+ default
+ if use test; then
+ mv "sample-files-${SAMPLE_COMMIT}"/* "${S}"/sample-files/ || die
+ fi
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ tests/test_reader.py::test_decode_permissions
+ tests/test_workflows.py::test_text_extraction_layout_mode
+ # rely on -Werror
+ tests/test_utils.py::test_deprecate_no_replacement
+ tests/test_workflows.py::test_orientations
+ tests/test_writer.py::test_remove_image_per_type
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -o addopts= -m "not enable_socket"
+}