summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-01-08 22:16:34 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-01-08 22:44:53 +0100
commite95728d54a8a9c7e46fcd385099d5339175bcbdd (patch)
treeb0883166b142547c90b3a2542c35ba6b46d5db98
parentdev-qt/qtnetworkauth: 5.15.8 version bump (diff)
downloadgentoo-e95728d54a8a9c7e46fcd385099d5339175bcbdd.tar.gz
gentoo-e95728d54a8a9c7e46fcd385099d5339175bcbdd.tar.bz2
gentoo-e95728d54a8a9c7e46fcd385099d5339175bcbdd.zip
dev-qt/qtpaths: 5.15.8 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--dev-qt/qtpaths/Manifest2
-rw-r--r--dev-qt/qtpaths/qtpaths-5.15.8.ebuild28
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-qt/qtpaths/Manifest b/dev-qt/qtpaths/Manifest
index 430f11ec9085..bc45060e0e0a 100644
--- a/dev-qt/qtpaths/Manifest
+++ b/dev-qt/qtpaths/Manifest
@@ -1,2 +1,4 @@
DIST qttools-5.15.7-gentoo-kde-1.tar.xz 1016 BLAKE2B 2269c02954d34a2862585228b2e3a3536a4b6f37b93c170571afa83d5e9c601684d1bf3d961d8be84acf8af074f4fdf929614c03ba262de8056af778bd41ac71 SHA512 0ac735a9e54fa147a495403e710a75aaf3ab4d2cb51a5db783d7b4b401bc2d6f46bb451d3afaa0efef57fe0dbd1aad95ab3262d88eafeb1f533314132cf400e6
+DIST qttools-5.15.8-gentoo-kde-1.tar.xz 1020 BLAKE2B 1585a66678f318e38b50b17a52f3efd1b53c9c13ceaf63a21fb532ad55790d1f8a5829a10d064de0a7d6efce47bc672916c580b5222f43c35f7869371fc91857 SHA512 e1333e15b1d2f546f6c2164a7da0ef684c024cfa48b847d5671716fa789fdab7e1ed50f3be6efe09e56578c62dd6029aa1fa1546d34b53bba9894445b58aa860
DIST qttools-everywhere-opensource-src-5.15.7.tar.xz 8900816 BLAKE2B c414cd92eeb7b3cc1b90c1bbb77409ba4e6f33b36cef9376a49068d8698461f211f062d5a7e80321e62ae2dd84f476252658ce3f0239d710945378d8ddfb01d4 SHA512 40176727d8c8430171483fd5815c1f84b8fc4d1a1b26b943c817e9a14cfe2d155c76039593f68f45b7e9276189968f3b37e1b17fd99adda7664582bf30a3935a
+DIST qttools-everywhere-opensource-src-5.15.8.tar.xz 8898368 BLAKE2B ea99e5bdf86d6d48fabd45bf55a48e5604d1a1e938a12838d3a928449d41354c4986401e7f159718432004f7357e28c88d7939f32bc2942bda1cb3abb8e28c33 SHA512 1248b61e21d1bab30c6f8380af0b83ffd2c5f4e75b2906f561f8aae3a8be2e426ca4ffa28164d64a90cc75c570652229847c7009b7aec63c6ba8e977dbdd4f4f
diff --git a/dev-qt/qtpaths/qtpaths-5.15.8.ebuild b/dev-qt/qtpaths/qtpaths-5.15.8.ebuild
new file mode 100644
index 000000000000..4f1248d19ada
--- /dev/null
+++ b/dev-qt/qtpaths/qtpaths-5.15.8.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} != *9999* ]]; then
+ QT5_KDEPATCHSET_REV=1
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+fi
+
+QT5_MODULE="qttools"
+inherit qt5-build
+
+DESCRIPTION="Command line client to QStandardPaths"
+
+IUSE=""
+
+DEPEND="=dev-qt/qtcore-${QT5_PV}*"
+RDEPEND="${DEPEND}"
+
+QT5_TARGET_SUBDIRS=(
+ src/qtpaths
+)
+
+src_install() {
+ qt5-build_src_install
+ qt5_symlink_binary_to_path qtpaths 5
+}