summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRonny (tastytea) Gutbrod <gentoo@tastytea.de>2022-06-24 13:59:50 +0200
committerSam James <sam@gentoo.org>2022-06-25 03:50:21 +0100
commite95b6ad3a5e4b943a76988a8c2fa52f681f323aa (patch)
treec76fc7dbef9391dc35d3f57e446bacd8406f891d
parentwww-apps/hugo: Increase test timeout (diff)
downloadgentoo-e95b6ad3a5e4b943a76988a8c2fa52f681f323aa.tar.gz
gentoo-e95b6ad3a5e4b943a76988a8c2fa52f681f323aa.tar.bz2
gentoo-e95b6ad3a5e4b943a76988a8c2fa52f681f323aa.zip
www-apps/hugo: add 0.101.0
Signed-off-by: Ronny (tastytea) Gutbrod <gentoo@tastytea.de> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--www-apps/hugo/Manifest2
-rw-r--r--www-apps/hugo/hugo-0.101.0.ebuild93
2 files changed, 95 insertions, 0 deletions
diff --git a/www-apps/hugo/Manifest b/www-apps/hugo/Manifest
index 3cc46dbf0338..57cf5f75d850 100644
--- a/www-apps/hugo/Manifest
+++ b/www-apps/hugo/Manifest
@@ -1,3 +1,5 @@
+DIST hugo-0.101.0-vendor.tar.xz 5682852 BLAKE2B 130cf9fda4d857e69144147e408a90fd28273d42919c4ea50228b795b7c35f9641857f642be8628b947b213ee42f11f468ca76317d4742d09c60bc5a272e83ff SHA512 07390ebb9daf2097010013f5e7c789f3fcee485952968b0934cc5d625eec9a79784ccda1414e59a21073b66389c75888704f923675f255df5eaa0d43c0cc3048
+DIST hugo-0.101.0.tar.gz 28130925 BLAKE2B ff35c48c39dac61abe56ba4f75bfddcdda700b71157dc4ed75f1c3724b11b8a9f4546e94d3105a724a5493b3baa73056a55d9d90e87ce4237e39213995db636d SHA512 541d0e04e868845119f2b488fd53b92929ea4dc08685d438a2914b41586e204588b193522013e8eed908dc0c3fbc2714aefb1afad0beae875d57d71aadc59c70
DIST hugo-0.98.0-vendor.tar.xz 5675060 BLAKE2B d876207dfc7c13ff97249bf72bf5191a0d4adbf82af38b8962a8e66d922f5bdf5298c8ecddb05c8a1d13f95f9e8bbbb84dec8cc37538ad47d8d83da951dfa003 SHA512 7b67920c8adcc8aea3a3dd6880716a79df8081cca17bf2d8cbd0ca3861aa69c29b0320eb86e0942db32e362b22faaade7cb65c9a0e0f88578504bfe4ed666d63
DIST hugo-0.98.0.tar.gz 27716005 BLAKE2B b3cbc9c616eb79a993bd9ddf07658ff1d3ce0680d3788e37cab78dfb48b33a259514b417d3e657afe89f188b3c0c03b88108dbcbd44d80c4d97004f7aa0185b0 SHA512 9d8a65c49be5b7bb181627bd8b557ddc041dc00a673ac0af8aeacbbfc46441a0045a5ab531087fb866d076297d67823a2eb5b14f57f3ecf57cc7b9e6b90ddf3a
DIST hugo-0.99.1-vendor.tar.xz 5675228 BLAKE2B 80fdd25fe924bcde7f200b805bf6598dbb726bb628b82e9b0d2809414a7a6e33cbfe069e29953e75b8ed4ecdb9c7303b44a8d8195b43540977cd7461295de109 SHA512 88ffb6bea777e3a72dac05941de542acdc6a17faff9e98517e483e17c7a42d1ab5aa7e65ed3a91f6832468d2da3e98e87346118694a8e20f6375fad56d5d7ff0
diff --git a/www-apps/hugo/hugo-0.101.0.ebuild b/www-apps/hugo/hugo-0.101.0.ebuild
new file mode 100644
index 000000000000..27abe895a52a
--- /dev/null
+++ b/www-apps/hugo/hugo-0.101.0.ebuild
@@ -0,0 +1,93 @@
+# Copyright 2018-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module bash-completion-r1
+
+DESCRIPTION="Fast static HTML and CSS website generator"
+HOMEPAGE="https://gohugo.io https://github.com/gohugoio/hugo"
+SRC_URI="
+ https://github.com/gohugoio/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://tastytea.de/files/gentoo/${P}-vendor.tar.xz
+"
+
+# NOTE: To create the vendor tarball, run:
+# `go mod vendor && cd .. && tar -caf ${P}-vendor.tar.xz ${P}/vendor`
+
+LICENSE="Apache-2.0 BSD BSD-2 MIT Unlicense"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc +sass test test-full"
+
+BDEPEND="
+ >=dev-lang/go-1.18
+ test? (
+ dev-python/docutils
+ dev-ruby/asciidoctor
+ test-full? ( app-text/pandoc )
+ )
+"
+RDEPEND="
+ media-libs/libwebp:=
+ sass? ( dev-libs/libsass:= )
+"
+DEPEND="${RDEPEND}"
+
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.96.0-unbundle-libwebp-and-libsass.patch"
+ "${FILESDIR}/${PN}-0.96.0-skip-some-tests.patch"
+ "${FILESDIR}/${PN}-0.99.1-test-timeout.patch"
+)
+
+src_configure() {
+ export CGO_ENABLED=1
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+
+ MY_BUILDFLAGS="$(usev sass "-tags extended")"
+
+ default
+}
+
+src_compile() {
+ mkdir -pv bin || die
+ ego build -ldflags "-X github.com/gohugoio/hugo/common/hugo.vendorInfo=gentoo:${PVR}" \
+ ${MY_BUILDFLAGS} -o "${S}/bin/hugo"
+
+ bin/hugo gen man --dir man || die
+
+ mkdir -pv completions || die
+ bin/hugo completion bash > completions/hugo || die
+ bin/hugo completion fish > completions/hugo.fish || die
+ bin/hugo completion zsh > completions/_hugo || die
+
+ if use doc ; then
+ bin/hugo gen doc --dir doc || die
+ fi
+}
+
+src_test() {
+ ego test -race "./..." ${MY_BUILDFLAGS}
+}
+
+src_install() {
+ dobin bin/*
+ doman man/*
+
+ dobashcomp completions/${PN}
+
+ insinto /usr/share/fish/vendor_completions.d
+ doins completions/${PN}.fish
+
+ insinto /usr/share/zsh/site-functions
+ doins completions/_${PN}
+
+ if use doc ; then
+ dodoc -r doc/*
+ fi
+}